This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1285380 - [gtk3] [wayland] can't open subsurfaces (menus)
[gtk3] [wayland] can't open subsurfaces (menus)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 08:56 EST by Christian Stadelmann
Modified: 2015-12-04 14:19 EST (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-5.0.3.2-10.fc23 libreoffice-5.0.3.2-11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 14:19:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-11-25 08:56:51 EST
Description of problem:
Libreoffice-gtk3 on wayland (GDK_BACKEND=wayland) can't open any menus at all.

Version-Release number of selected component (if applicable):
libreoffice-5.0.3.2-4.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. do any action that triggers opening a menu (e.g. context click, using <Alt>+key, main menu, …

Actual results:
No menu shows up. Error message (cli):

(soffice:13204): Gdk-WARNING **: Couldn't map as window 0x55a57bb9fcf0 as susburface yet because it doesn't have a parent

Expected results:
Menu should show up.
Comment 1 Fedora Update System 2015-12-01 06:52:01 EST
libreoffice-5.0.3.2-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8cdbd2bb12
Comment 2 Fedora Update System 2015-12-01 17:30:25 EST
libreoffice-5.0.3.2-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libreoffice'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8cdbd2bb12
Comment 3 Fedora Update System 2015-12-03 04:54:50 EST
libreoffice-5.0.3.2-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-529302b34c
Comment 4 Fedora Update System 2015-12-03 15:20:10 EST
libreoffice-5.0.3.2-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2015-12-03 20:35:04 EST
libreoffice-5.0.3.2-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libreoffice'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-529302b34c
Comment 6 Fedora Update System 2015-12-04 14:19:25 EST
libreoffice-5.0.3.2-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.