Bug 1285393 - RHEV Hypervisor Custom naming scheme gets changed during installation to MAC address naming scheme
RHEV Hypervisor Custom naming scheme gets changed during installation to MAC ...
Status: CLOSED NOTABUG
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: TP2
: 1.0
Assigned To: dgao
Dave Johnson
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 09:15 EST by Antonin Pagac
Modified: 2016-08-12 16:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 13:13:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2015-11-25 09:15:30 EST
Description of problem:
During a deployment of RHEVM, I choose a Custom naming scheme for my Hypervisor hosts. For testing purposes, I input some invalid characters. I could see the invalid hostnames on the Installation Review screen at the start of the installation process, but after some time and a refresh of the page, my hostnames disappeared and were replaced by the MAC naming scheme. I can see the MAC naming scheme hostnames now on Installation Review page and also in step 2C Hypervisors, where the hosts have MAC naming scheme in spite of the Custom naming scheme being selected, but grayed out.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20151118.t.0-RHCI-x86_64-dvd1.iso

How reproducible:
?

Steps to Reproduce:
1. Start a deployment of RHEVM, in step 2C Hypervisors choose Custom naming scheme
2. (optional?) Input some invalid characters
3. Proceed with the deployment, start the installation
4. Wait a while after the content sync for the installation of RHEVM to begin
5. Refresh the Installation Review page
6. The Custom naming scheme hostnames changed to MAC naming scheme hostnames

Actual results:
Naming scheme for the Hypervisor hostnames changed during the deployment

Expected results:
Deployment completes with chosen naming scheme, no unannounced changes of the hostnames happen

Additional info:
My deploymend did not complete, it froze at 96.9%.
Comment 1 Antonin Pagac 2015-11-25 09:16:57 EST
See also: https://bugzilla.redhat.com/show_bug.cgi?id=1285375
Comment 3 dgao 2016-01-20 10:12:41 EST
Oops comment#2 applies for bz1285375, not this bz. Moving back to assigned.
Comment 4 dgao 2016-01-20 13:13:30 EST
This bug can no longer be reproduced since the UI no longer allows invalid characters to be entered for step 2C. Entering a proper alphanumeric hostname, we do not see it change during or after the deployment.

Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.