Bug 1285395 - uwsgi-2.0.11.2-5 build failed for ppc64le epel7
Summary: uwsgi-2.0.11.2-5 build failed for ppc64le epel7
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: uwsgi
Version: epel7
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jorge Gallegos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: epel7ppc64le
TreeView+ depends on / blocked
 
Reported: 2015-11-25 14:18 UTC by Menanteau Guy
Modified: 2015-12-28 21:26 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-12-28 21:26:35 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2015-11-25 14:18:15 UTC
I have a problem to build uwsgi-2.0.11.2-5 in my local ppc64le epel7 environment because of glusterfs dependancy and then on java library.

To avoid glusterfs dependancy I didi following correction in the spec file:
   # el7 doesn't have perl-Coro
   %bcond_with perl
   # el7 can now build glusterfs but not on PPC so that's neat
-  %ifarch ppc64
+  %ifarch ppc64 ppc64le
   %bcond_with glusterfs
   %else
   %bcond_without glusterfs

Then I got:
*** uWSGI building and linking plugin plugins/systemd_logger ***
[gcc -pthread] systemd_logger_plugin.so
build time: 0 seconds
*** systemd_logger plugin built and available in systemd_logger_plugin.so ***
+ CFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mcpu=power7 -mtune=power8 -Wno-unused-but-set-variable'
+ python uwsgiconfig.py --plugin plugins/jvm fedora
/usr/bin/ld: cannot find -ljvm
collect2: error: ld returned 1 exit status
using profile: buildconf/fedora.ini
detected include path: ['/usr/lib/gcc/ppc64le-redhat-linux/4.8.5/include', '/usr/local/include', '/usr/include']

Note that build go to the end if I remove uwsgi-ppc64le-java.patch from the spec file.

Comment 1 Peter Robinson 2015-12-06 08:39:31 UTC
> -  %ifarch ppc64
> +  %ifarch ppc64 ppc64le

This is wrong, it should be at the very least %{power64} but actually the proper fix is ifnarch x86_64

Comment 2 Fedora Update System 2015-12-06 08:51:02 UTC
uwsgi-2.0.11.2-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-af3a1b1684

Comment 3 Fedora Update System 2015-12-08 07:22:22 UTC
uwsgi-2.0.11.2-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update uwsgi'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-af3a1b1684

Comment 4 Fedora Update System 2015-12-11 16:07:44 UTC
uwsgi-2.0.11.2-7.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-af3a1b1684

Comment 5 Fedora Update System 2015-12-12 20:23:42 UTC
uwsgi-2.0.11.2-7.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update uwsgi'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-af3a1b1684

Comment 6 Fedora Update System 2015-12-28 21:26:31 UTC
uwsgi-2.0.11.2-7.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.