Bug 1285397 - Backport Neutron L3 performance fixes
Backport Neutron L3 performance fixes
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: z4
: 7.0 (Kilo)
Assigned To: Brent Eagles
Ofer Blaut
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 09:20 EST by Brent Eagles
Modified: 2016-04-26 22:30 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.2-7.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:09:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0260 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2016-02-18 16:05:15 EST

  None (edit)
Description Brent Eagles 2015-11-25 09:20:12 EST
Description of problem:

Several backportable improvements have been made to neutron in the Liberty cycle that remove extra overhead during normal operation.

As this is an intrinsic performance issue, it is in a sense 100% reproducible. However, there is no direct mechanism of quantifying the problem without invasive instrumentation of the code. Steps to reproduce might look like:

1. Configure a reasonable yet large number of routers
2. Monitor CPU usage of neutron server and responsiveness of operations

The actual results might be that the neutron server spikes to a sustained 100% CPU usage and loses responsiveness, while the expected result is that it fluctuates according to user activity and the agent update cycle.
Comment 2 Ofer Blaut 2016-01-24 04:52:31 EST
code verified in openstack-neutron-2015.1.2-7.el7ost.noarch
Comment 6 errata-xmlrpc 2016-02-18 11:09:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0260.html

Note You need to log in before you can comment on or make changes to this bug.