Bug 1285405 - hamster requires python dbus module which is not installed
hamster requires python dbus module which is not installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
23
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 09:31 EST by anonCybGicEm
Modified: 2016-02-12 14:30 EST (History)
3 users (show)

See Also:
Fixed In Version: hamster-time-tracker-2.0-0.2.rc1.fc23 hamster-time-tracker-2.0-0.2.rc1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 06:53:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anonCybGicEm 2015-11-25 09:31:01 EST
Description of problem:
I installed hamster from the default repositories for Fedora 23.
Hamster needs the python debus module, but this was not installed.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. `sudo dnf install hamster-time-tracker`
2. `hamster`

Actual results:
Traceback (most recent call last):
  File "/usr/bin/hamster", line 30, in <module>
    from hamster import client, reports
  File "/usr/lib/python2.7/site-packages/hamster/client.py", line 24, in <module>
    import dbus, dbus.mainloop.glib
ImportError: No module named dbus


Expected results:
Expected hamster-time-tracking window to open.


Additional info:
Comment 1 anonCybGicEm 2015-11-25 09:47:32 EST
Looks like all that's required to fix this is `dnf install dbus-python`. So the hamster-time-tracker package just needs to install dbus-python as a dependency.
Comment 2 Ankur Sinha (FranciscoD) 2015-11-25 09:59:54 EST
I'll add the dep. What DE are you using anyway? I thought stuff like dbus gets pulled in by most of them.
Comment 3 anonCybGicEm 2015-11-25 10:05:21 EST
Gnome. I installed the default Fedora 23 Workstation.
Comment 4 Fedora Update System 2016-02-02 15:45:38 EST
hamster-time-tracker-2.0-0.1.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e5b4e5be06
Comment 5 Fedora Update System 2016-02-02 17:04:01 EST
hamster-time-tracker-2.0-0.2.rc1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e7bfef7108
Comment 6 Fedora Update System 2016-02-02 17:04:01 EST
hamster-time-tracker-2.0-0.2.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-01bd33e7e6
Comment 7 Fedora Update System 2016-02-03 18:01:11 EST
hamster-time-tracker-2.0-0.2.rc1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e7bfef7108
Comment 8 Fedora Update System 2016-02-03 18:25:46 EST
hamster-time-tracker-2.0-0.2.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-01bd33e7e6
Comment 9 Fedora Update System 2016-02-12 06:53:32 EST
hamster-time-tracker-2.0-0.2.rc1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-02-12 07:21:15 EST
hamster-time-tracker-2.0-0.2.rc1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.