Bug 128542 - cannot re-number ethernet interfaces in graphical install
cannot re-number ethernet interfaces in graphical install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-24 16:49 EDT by John Reiser
Modified: 2015-11-26 10:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-26 23:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-07-24 16:49:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
During install, the numbering of physical ethernet interfaces cannot
be controlled.  If there are two interfaces, then something [kudzu?]
assigns eth0 and eth1, and there is no way to change the assignment. 
This is problematic because the default order is different from some
previous RedHat systems (thus the order chosen by Fedora Core 3 test 1
installer must be re-worked after installation for compatibility with
multibooting other systems), and because physical cabling and
third-party firewall packages may impose a different order.  Also, in
many cases the built-in interface has a more-efficient path to memory
(a direct to a port on the memory controller, or at least through
fewer PCI bridges).

Version-Release number of selected component (if applicable):
anaconda-10.0.1-2

How reproducible:
Always

Steps to Reproduce:
1. Fresh graphical install on a system with more than one ethernet
interface.
2.
3.
    

Actual Results:  The assignment of eth0, eth1, ... to physical
interfaces cannot be changed in the network configuration dialogs.  On
a system with two interfaces (sis900 builtin, e100 PCI card) then the
PCI card gets eth0 and the builtin sis900 gets eth1.

Expected Results:  The user should be able to control the assignment
of names to physical interfaces.  eth0 should not be assigned to a
plug-in interface unless there is no other choice.  eth0 should be
assigned to a builtin interface if possible.

Additional info:
Comment 1 Jeremy Katz 2004-07-26 23:49:29 EDT
No, anaconda is not going to provide a mechanism for renaming
interfaces.  Doing so is crack.  You can do adjustments post-install,
but it is a corner case that should not be put on the path of everyone
installing the system.

As far as the ordering changing, blame the kernel and/or acpi.

Note You need to log in before you can comment on or make changes to this bug.