Bug 1285442 - workrave crashes, related to gtkmm
Summary: workrave crashes, related to gtkmm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: workrave
Version: 23
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Yaakov Selkowitz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1267729 1294323
TreeView+ depends on / blocked
 
Reported: 2015-11-25 15:36 UTC by Jacek Wielemborek
Modified: 2016-03-09 20:11 UTC (History)
5 users (show)

Fixed In Version: workrave-1.10.10-1.fc23 workrave-1.10.10-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-03 20:24:53 UTC


Attachments (Terms of Use)

Description Jacek Wielemborek 2015-11-25 15:36:24 UTC
Description of problem:

Workrave crashes when it's time for break

Version-Release number of selected component (if applicable):

1.10-9

How reproducible:

Always

Steps to Reproduce:
1. Run workrave
2. Right click the tray
3. Select "break"

Actual results:

+ gdb workrave -ex 'r '
GNU gdb (GDB) Fedora 7.10-29.fc23
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...

warning: ~/.gdbinit.local: No such file or directory
Reading symbols from workrave...Reading symbols from /mnt/sda/d33tah/workspace/workrave-1.10/workrave...(no debugging symbols found)...done.
(no debugging symbols found)...done.
Starting program: /usr/bin/workrave 
warning: the debug information found in "/usr/lib/debug//usr/lib64/libSM.so.6.0.1.debug" does not match "/lib64/libSM.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libICE.so.6.3.0.debug" does not match "/lib64/libICE.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXtst.so.6.1.0.debug" does not match "/lib64/libXtst.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXss.so.1.0.0.debug" does not match "/lib64/libXss.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libX11.so.6.3.0.debug" does not match "/lib64/libX11.so.6" (CRC mismatch).

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
warning: the debug information found in "/usr/lib/debug//usr/lib64/libXext.so.6.4.0.debug" does not match "/lib64/libXext.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXi.so.6.1.0.debug" does not match "/lib64/libXi.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libX11-xcb.so.1.0.0.debug" does not match "/lib64/libX11-xcb.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libz.so.1.2.8.debug" does not match "/lib64/libz.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXfixes.so.3.1.0.debug" does not match "/lib64/libXfixes.so.3" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXinerama.so.1.0.0.debug" does not match "/lib64/libXinerama.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXrandr.so.2.2.0.debug" does not match "/lib64/libXrandr.so.2" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXcursor.so.1.0.2.debug" does not match "/lib64/libXcursor.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libwayland-egl.so.1.0.0.debug" does not match "/lib64/libwayland-egl.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libEGL.so.1.0.0.debug" does not match "/lib64/libEGL.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXrender.so.1.3.0.debug" does not match "/lib64/libXrender.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libGL.so.1.2.0.debug" does not match "/lib64/libGL.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libXau.so.6.0.0.debug" does not match "/lib64/libXau.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libattr.so.1.1.0.debug" does not match "/lib64/libattr.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libbz2.so.1.0.6.debug" does not match "/lib64/libbz2.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libgbm.so.1.0.0.debug" does not match "/lib64/libgbm.so.1" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//usr/lib64/libglapi.so.0.0.0.debug" does not match "/lib64/libglapi.so.0" (CRC mismatch).

[New Thread 0x7fffe0f45700 (LWP 22063)]
[New Thread 0x7fffdbfff700 (LWP 22064)]
[New Thread 0x7fffdb7fe700 (LWP 22065)]

Program received signal SIGSEGV, Segmentation fault.
-----------------------------------------------------------------------------------------------------------------------[regs]
  RAX: 0x00007FFFFFFFCDD0  RBX: 0x0000555555B9D3D0  RBP: 0x0000000000000050  RSP: 0x00007FFFFFFFCDA0  o d I t s z a P c 
  RDI: 0x0000555555B9D3D0  RSI: 0x0000000000000050  RDX: 0x0000000000000001  RCX: 0x0000000000000000  RIP: 0x00007FFFF60228A1
  R8 : 0x0000555555F95D48  R9 : 0x00007FFFF2863558  R10: 0x0000555555F78C40  R11: 0x0000000000000000  R12: 0x0000555555BEB350
  R13: 0x00007FFFFFFFCE60  R14: 0x0000555555600610  R15: 0x0000555555EB4730
  CS: 0033  DS: 0000  ES: 0000  FS: 0000  GS: 0000  SS: 002B
-----------------------------------------------------------------------------------------------------------------------[code]
=> 0x7ffff60228a1 <_ZNK3Gtk6Widget14get_allocationEv+17>:       mov    rax,QWORD PTR [rbp+0x0]
   0x7ffff60228a5 <_ZNK3Gtk6Widget14get_allocationEv+21>:       mov    rsi,rbx
   0x7ffff60228a8 <_ZNK3Gtk6Widget14get_allocationEv+24>:       mov    rax,QWORD PTR [rax-0x18]
   0x7ffff60228ac <_ZNK3Gtk6Widget14get_allocationEv+28>:       mov    rdi,QWORD PTR [rbp+rax*1+0x8]
   0x7ffff60228b1 <_ZNK3Gtk6Widget14get_allocationEv+33>:       call   0x7ffff5f4bc50 <gtk_widget_get_allocation@plt>
   0x7ffff60228b6 <_ZNK3Gtk6Widget14get_allocationEv+38>:       add    rsp,0x8
   0x7ffff60228ba <_ZNK3Gtk6Widget14get_allocationEv+42>:       mov    rax,rbx
   0x7ffff60228bd <_ZNK3Gtk6Widget14get_allocationEv+45>:       pop    rbx
-----------------------------------------------------------------------------------------------------------------------------
0x00007ffff60228a1 in Gtk::Widget::get_allocation() const () from /lib64/libgtkmm-3.0.so.1
Missing separate debuginfos, use: dnf debuginfo-install workrave-1.10-9.fc23.x86_64
gdb$ bt
#0  0x00007ffff60228a1 in Gtk::Widget::get_allocation() const () at /lib64/libgtkmm-3.0.so.1


Expected results:

No crash

Additional info:

https://bbs.archlinux.org/viewtopic.php?id=203726

Comment 1 info 2015-12-03 05:59:16 UTC
Looks like when I remove the .workrave folder from my profile, workrave does not start at all:


[bar@bartop ~]$ gdb workrave -ex 'r '
GNU gdb (GDB) Fedora 7.10-29.fc23
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from workrave...Reading symbols from /usr/lib/debug/usr/bin/workrave.debug...done.
done.
Starting program: /usr/bin/workrave 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffe0f41700 (LWP 4274)]
[New Thread 0x7fffdbfff700 (LWP 4275)]
[New Thread 0x7fffdb7fe700 (LWP 4276)]

Program received signal SIGSEGV, Segmentation fault.
Gtk::Widget::get_allocation (this=0x50) at widget.cc:506
506	  gtk_widget_get_allocation(const_cast<GtkWidget*>(gobj()), allocation.gobj());
Missing separate debuginfos, use: dnf debuginfo-install bzip2-libs-1.0.6-17.fc23.x86_64 flac-libs-1.3.1-5.fc23.x86_64 libgcc-5.1.1-4.fc23.x86_64 libstdc++-5.1.1-4.fc23.x86_64

Comment 2 Fedora Admin XMLRPC Client 2015-12-26 12:05:31 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Admin XMLRPC Client 2015-12-28 18:27:31 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Andris Pavenis 2016-02-20 05:13:06 UTC
RPM source package does not even build in Fedora 23 x86_64 any more.

From other side:

current branch_v1_10_10 (2016-02-20) from GitHub builds and seems to work under the same system after trivial include guards fix for backend/src/GSSettingsConfigurator.hh. I did not specify any configure options. Path would likely not be required with configure options used for Fedora RPM package build

Comment 5 Fedora Update System 2016-02-26 22:15:27 UTC
workrave-1.10.10-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-512f1582a3

Comment 6 Fedora Update System 2016-02-26 22:16:17 UTC
workrave-1.10.10-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a5ec37671

Comment 7 Fedora Update System 2016-02-28 13:53:21 UTC
workrave-1.10.10-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a5ec37671

Comment 8 Fedora Update System 2016-02-28 13:55:15 UTC
workrave-1.10.10-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-512f1582a3

Comment 9 Fedora Update System 2016-03-03 20:24:21 UTC
workrave-1.10.10-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-03-09 16:21:23 UTC
workrave-1.10.10-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-03-09 18:46:03 UTC
workrave-1.10.10-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-03-09 20:11:38 UTC
workrave-1.10.10-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.