Bug 1285450 - Can select more than one subscription management application after creating a new one
Can select more than one subscription management application after creating a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity high
: TP2
: 1.0
Assigned To: Erik Nelson
Dave Johnson
: Triaged
Depends On:
Blocks: rhci-sprint-12
  Show dependency treegraph
 
Reported: 2015-11-25 10:50 EST by Antonin Pagac
Modified: 2016-10-03 15:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:03:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2015-11-25 10:50:25 EST
Description of problem:
After creating new Subscription management application, I'm able to select more than one radio button, meaning I can select more than one Subscription management application to be used for my deployment.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20151118.t.0-RHCI-x86_64-dvd1.iso
Firefox 42.0

How reproducible:
Always

Steps to Reproduce:
1. Start a new deployment, go to step Subscription Management Application
2. Create a new one using button "New Subscription Management Application", submit
3. Select the newly created application
4. Select any other application. They stay selected, you can select all applications in the table

Actual results:
User can select more than one Subscription management application for one deployment

Expected results:
User can select only one Subscription management application for one deployment

Additional info:
The most recently selected application seems to actually be chosen for the deployment when hitting the Next button.
Comment 1 jmagen@redhat.com 2016-01-13 09:34:35 EST
I can't duplicate this.
Open PR that is related to creating subscription management applications
https://github.com/fusor/fusor/pull/619
Comment 2 Erik Nelson 2016-01-13 10:52:51 EST
I can't reproduce this either, is it possible this is fixed?
Comment 3 jmagen@redhat.com 2016-01-14 03:18:56 EST
I think it's fixed. Changing status to modified.
Comment 4 Antonin Pagac 2016-01-15 06:45:16 EST
Verified.

RHCI-6.0-RHEL-7-20160114.t.0-RHCI-x86_64-dvd1.iso

Note You need to log in before you can comment on or make changes to this bug.