Bug 1285461 - [RFE] Improve formatting of "atomic images" output
[RFE] Improve formatting of "atomic images" output
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Brent Baude
atomic-bugs@redhat.com
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 11:18 EST by Yoana Ruseva
Modified: 2016-03-31 19:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:25:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yoana Ruseva 2015-11-25 11:18:33 EST
Description of problem:

When you run "atomic images", the columns in the output are misaligned.

Version-Release number of selected component (if applicable):

atomic-1.6-6.gitca1e384.el7.x86_64

How reproducible:

always

Steps to Reproduce:


Actual results:

-bash-4.2# atomic images
 REPOSITORY                          TAG                 IMAGE ID            CREATED             VIRTUAL SIZE
 registry.access.redhat.com/rhel7/rsyslog latest              00b31ffda5e9        2015-10-30 10:37    202.89 MB   
 docker.io/rhel7/rhel-tools          latest              578f02676897        2015-10-30 10:08    1.07 GB     
 registry.access.redhat.com/rhel7    latest              c4f590bbcbe3        2015-10-30 07:40    158.23 MB   
 registry.access.redhat.com/rhel6    latest              d5b570729de6        2015-09-16 15:21    166.1 MB    
 docker-registry.usersys.redhat.com/atomicga/sadc 7.1-1               a0e29b478e9a        2015-02-12 08:23    182.93 MB   


Expected results:

Perhaps:

-bash-4.2# docker images
REPOSITORY                                         TAG                 IMAGE ID            CREATED             VIRTUAL SIZE
registry.access.redhat.com/rhel7/rsyslog           latest              00b31ffda5e9        3 weeks ago         202.9 MB
docker.io/rhel7/rhel-tools                         latest              578f02676897        3 weeks ago         1.066 GB
registry.access.redhat.com/rhel7                   latest              c4f590bbcbe3        3 weeks ago         158.2 MB
registry.access.redhat.com/rhel6                   latest              d5b570729de6        9 weeks ago         166.1 MB
docker-registry.usersys.redhat.com/atomicga/sadc   7.1-1               a0e29b478e9a        9 months ago        182.9 MB


Additional info:
Comment 1 Brent Baude 2015-11-30 14:32:55 EST
A fix for this was pushed into atomic master:

https://github.com/projectatomic/atomic/commit/c9a028ece05e81fd53b8bce72d598149d04c651c

Are you able to pull master and see if this remedies your RFE and provide feedback here please.
Comment 2 Daniel Walsh 2015-12-01 17:13:00 EST
Fixed in atomic-1.8
Comment 4 Alex Jia 2016-02-01 00:22:13 EST
It looks fine on atomic-1.8-6.git1bc3814.el7.x86_64, so move the bug to VERIFIED status.


# atomic images
REPOSITORY                                           TAG    IMAGE ID     CREATED             VIRTUAL SIZE
 centos_stop_label                                   latest 3e7ae7fa2964 2016-02-01 11:41    196.63 MB 
 busybox_label                                       latest b400a4e19136 2016-01-21 11:40    1.11 MB   
 docker.io/centos                                    latest c8a648134623 2015-12-24 23:30    196.63 MB 
 docker.io/busybox                                   latest fc0db02f3072 2015-12-09 02:31    1.11 MB   
 registry.access.redhat.com/rhel7/rhel-tools         latest fd2acbeb2b97 2015-12-04 18:44    1.16 GB   
 registry.access.redhat.com/rhel7/rsyslog            latest b98636a98907 2015-12-03 18:02    214.12 MB 
 docker-registry.usersys.redhat.com/micah/fedora-uat latest fc918be8d896 2015-07-17 00:12    1.26 GB
Comment 6 errata-xmlrpc 2016-03-31 19:25:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0527.html

Note You need to log in before you can comment on or make changes to this bug.