Bug 1285500 - AttributeError: module 'html.parser' has no attribute 'HTMLParseError'
AttributeError: module 'html.parser' has no attribute 'HTMLParseError'
Product: Fedora EPEL
Classification: Fedora
Component: python-django (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-11-25 14:08 EST by John Dulaney
Modified: 2015-11-26 09:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-26 09:58:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
htmlparseerror.patch (554 bytes, patch)
2015-11-25 14:08 EST, John Dulaney
no flags Details | Diff

  None (edit)
Description John Dulaney 2015-11-25 14:08:47 EST
Created attachment 1098939 [details]

Description of problem:
When building on for python 3.5, I get the following error:

AttributeError: module 'html.parser' has no attribute 'HTMLParseError'

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Build using python 3.5

Actual results:
Build fails

Expected results:
Build completes

Additional info:
This is a known issue with django that has been fixed upstream(0).  Accordingly, would it be possible to apply the (attached) patch to the epel package?

(0)  https://github.com/django/django/commit/b07aa52e8a8e4c7fdc7265f75ce2e7992e657ae9

PS, yes, I know epel doesn't officially support python 3.5, but this is for my own project.
Comment 1 John Dulaney 2015-11-25 14:32:13 EST
You know instead, make this a request to update to the latest django in epel7.  If you can't do that, then let me know and go ahead and close this here ticket.
Comment 2 Matthias Runge 2015-11-26 02:47:41 EST
Unfortunately I can't update to 1.8.x, as for example reviewboard requires Django-1.6.
I will look into cherry-picking above commit, as we're already carrying several patches.

If you want Django-1.8, you should be able to pick it from CentOS cloud repository, OpenStack Kilo (or later) runs on Django-1.8; admitted, that's python2-django, no python3 version.
Comment 3 John Dulaney 2015-11-26 09:58:20 EST
I built from the latest srpm in Fedora; we can go ahead and close this.

Note You need to log in before you can comment on or make changes to this bug.