Bug 128557 - aacraid fedura core 2 tyan 2882 amd64 crash
aacraid fedura core 2 tyan 2882 amd64 crash
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-26 10:10 EDT by alan barrow
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alan barrow 2004-07-26 10:10:09 EDT
Description of problem:
tyan 2882 motherboard
adaptec 2120s raid -- 2x34GB discs RAID 1
2GB ram
dual 246/248

Version-Release number of selected component (if applicable):
fedora core 2

How reproducible:
100%

Steps to Reproduce:
1. Insert cdrom and boot from
   Then any of the following
      * hit [enter]
      * linux iommu=off
      * linux iommu=off acpi=off
      * linux iommu=off acpi=off text
      * linux iommu=off acpi=off text noprobe
        * and all combinations of the above

2. Graphical :-
   select english / UK
   custom
   partition with disk druid --> system complete freeze

3. Text :- (noprobe)
   Select english / UK
   module choice = aacraid only......
   partition with disk druid --> system freeze, anaconda crash
   blue background -- white text in russian (it seems)

Actual results:
[ctrl]+[F3-F4] anaconda looses interupt to hda, hda=cdrom
System freeze on any select of custom / disk druid.

Expected results:
Disk Druid starting.

Additional info:
Machine BIOS :-
options tried :-
   * PNP OS = off
   * BBS = off
   * acpi = off
   * usb = off
   * boot sector protect = off

Adaptec 2120S BIOS :-
Controller options :-
   * BBS off
Comment 1 Jeff Fisher 2004-10-25 10:22:42 EDT
We are experiencing the same problem here.

Tyan S2882 motherboard
2 x Opteron 244
4 gigs of ram
Adaptec 2120S 64 bit card.
4 x 74 gig 15k SCSI drives setup in a RAID10.

Soon as we attempt to go into Disk Druid -- we get a blue screen with
gibberish on it.

Comment 2 dijuremo 2004-10-29 07:34:23 EDT
We are seing the same problem here with Tyan S2882.

At first we though it was a problem with the jumpers on the
motherboard.  It comes by default configured to run in PCI-X Mode at
100Mhz.  Our card is the  "Adaptec Serial ATA RAID 21610SA" which is
only PCI and should run at 66Mhz.  After adjusting jumpers on the
motherboard, we found the same crashing behaviour.

We were able to install FC2 just fine from DVD (kickstart would crash
too).  Then we used a gentoo cd to boot, chroot into the FC2 install
and updated the kernel to the latest.  With the latest smp kernel
(2.6.8-1.521.x86_64), the machine will start "init" just fine, but
then right after mounting swap it will hang saying it had problems
with the / filesystem.

We then tested a gentoo install to rule out a Hardware problem.  It
worked fine.  Last test was FC3 test 3 and everything works perfectly.

Diego
Comment 3 Ladar Levison 2004-11-02 11:43:21 EST
Same problem here. System crashes with blue screen, and binary characters.

Always occurs right after loading the aarcraid driver. I have not
figured out a way around this issue...

I have tried booting with noprobe, and selecting the aarcraid driver
manually, only to encounter the same issue.

System Config :

Tyan S2881
Adaptec 2120S
4x 1G KVR
6x Seagate 146G
2x AMD 246
Comment 4 Ladar Levison 2004-11-12 14:36:38 EST
I found a possible solution. I am able to boot the installer in text
mode by specifying 'linux mem=128m text'. However I can't get the OS
to boot once I install. I am now using FC3, so this bug should be
considered relevant to the current release.
Comment 5 Ladar Levison 2004-11-12 17:28:19 EST
FC3 hangs with : "PCI: Probing PCI hardware (bus 00)"
Comment 6 Dave Jones 2005-04-16 01:53:36 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.