This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 128558 - cannot open terminal(s)
cannot open terminal(s)
Status: CLOSED DUPLICATE of bug 128154
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-26 10:28 EDT by pascal kolijn
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description pascal kolijn 2004-07-26 10:28:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040629 Firefox/0.9.1

Description of problem:
after a some time working with the gnome desktop (don't know if it
happens in kde, not using it) the gnome-terminal stops functioning
properly.

When trying to open a new tab: it takes about 20 seconds and an empty
tab turns up, but no shell.

when trying to start a xterm from a still working terminal the
following message appears:

get_pty: not enough ptys

it seems to downgrade from here closing a working shells allows you to
create a new, if you are lucky.....

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start up gnome open a lot of shells
2. and after a day or sooner you can not open a new one
3.
    

Actual Results:  see desc.

Expected Results:  a new terminal

Additional info:

googled it. and it might be udev(or something like it) related but I'm
not quiet sure howto debug this.

only a reboot helps.....
Comment 1 Bob Gustafson 2004-07-26 12:32:16 EDT
I get same thing.

After a reboot, I opened 20 gnome-terminal windows. Each opened in the
blink of an eye, nicely cascaded. Then I clicked them cloased.

Same for a vnc connected user. Same nice action.

---

Then, after some time - a day or so. My uptime says 2 days 3 hrs, but
I had problems last night.

I just now tried to open a new window - content was black. Then after
some timeout interval - maybe 60 seconds, the content turned white,
but no blinking cursor or '#' prompt showed up.

Looking at /var/log/messages, I saw:

Jul 26 09:42:23 hoho2 pam_timestamp_check: pam_timestamp: `/' owner
UID != 0
Jul 26 09:42:54 hoho2 last message repeated 13 times
Jul 26 09:43:58 hoho2 last message repeated 25 times
Jul 26 09:44:59 hoho2 last message repeated 25 times
Jul 26 09:46:03 hoho2 last message repeated 25 times
...
...
lots more identical lines..
Comment 2 Ray Strode [halfline] 2004-07-26 12:59:19 EDT
Hi.

This bug is a duplicate of bug 128154.  You can track its progress there.

*** This bug has been marked as a duplicate of 128154 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.