Bug 1285600 - Bump up Facter version to 3.x [NEEDINFO]
Bump up Facter version to 3.x
Status: NEW
Product: Fedora EPEL
Classification: Fedora
Component: facter (Show other bugs)
epel7
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 21:22 EST by Gilles Dubreuil
Modified: 2018-03-28 00:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gdubreui: needinfo? (vanmeeuwen+fedora)


Attachments (Terms of Use)

  None (edit)
Description Gilles Dubreuil 2015-11-25 21:22:35 EST
Facter 3 provides proper IPv6 support.

Effectively facter 2.x has incomplete facts for IPv6 interfaces, netmask6 for instance are missing.

Facter 3 is a complete rewrite, which turns to be much faster.
Comment 1 Ian Mortimer 2018-03-27 23:51:01 EDT
An upgrade at least to 2.4.6 would fix some bugs.

Thanks
-- 
Ian
Comment 2 Gilles Dubreuil 2018-03-28 00:47:09 EDT
Seems like Facter has been left behind. Is there any reason or blocker for moving forward?

Note You need to log in before you can comment on or make changes to this bug.