Bug 1285601 - Incorrect ordering of boot menu entries generated by grubby
Incorrect ordering of boot menu entries generated by grubby
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grubby (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: rmarshall
Release Test Team
: ZStream
: 1398811 (view as bug list)
Depends On:
Blocks: 1203710 1295926 1313485 1420746 1420748 1420749
  Show dependency treegraph
 
Reported: 2015-11-25 21:28 EST by Kathryn Dixon
Modified: 2017-12-04 10:07 EST (History)
18 users (show)

See Also:
Fixed In Version: grubby-8.28-18
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1420746 1420748 1420749 (view as bug list)
Environment:
Last Closed: 2017-08-01 14:47:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kathryn Dixon 2015-11-25 21:28:30 EST
Description of problem:

continuing from bug 1212128 , 

install rhel 7.2 and update or install multiple kernels
we not don't get systemd.debug but we do have mis-ordering of the kernels in the grub menu.

Version-Release number of selected component (if applicable):

How reproducible: 100%


Steps to Reproduce:
1. install rhel 7.2
2. install another kernel
3. kernels are now mismatched but grub defaults to highlighting on the correct kernel

Actual results:

kernels are in wrong order, but system will boot to correct one.


Expected results:

kernels to be in correct order in grub.

Additional info:
Comment 2 Martin Banas 2016-09-06 03:40:32 EDT
Hi Kathryn,
I'm not sure what's the requested behavior here. Could you please retest that the bug s fixed for you?

Thanks,
Martin
Comment 5 Jan Stodola 2016-09-16 04:58:37 EDT
Retested with grubby-8.28-18.el7:

[root@localhost ~]# echo "MAKEDEBUG=yes" >> /etc/sysconfig/kernel
[root@localhost ~]# yum install ./kernel-3.10.0-507.el7.x86_64.rpm

The result is that the non-debug boot entry is listed first, following the debug boot entry. The problem is that the debug entry is selected to be booted by default, which is not expected:

Red Hat Enterprise Linux Server (3.10.0-507.el7.x86_64) 7.3 (Maipo)       
Red Hat Enterprise Linux Server (3.10.0-507.el7.x86_64) 7.3 (Maipo) with>   << selected by default
Red Hat Enterprise Linux Server (3.10.0-506.el7.x86_64) 7.3 (Maipo)      
Red Hat Enterprise Linux Server (0-rescue-49a0cff6c58a443eba05fa166c4349>

Since the fix is incomplete, moving back to ASSIGNED.
Comment 9 rmarshall 2016-09-21 14:00:41 EDT
discussed with jstodola; moving this to 7.4 release; old behavior will remain for now.
Comment 11 Thomas Mueller 2016-11-09 11:13:33 EST
On RHEL 7.3 the order is now as expected (first normal, second with debugging) altough #c9 states "moving to 7.4 release"

but now the debugging entry is selected as default boot entry. 

see also: https://bugzilla.redhat.com/show_bug.cgi?id=1367792#c6
Comment 12 Paul Stauffer 2016-11-10 15:00:42 EST
It sounds like two distinct problems are being discussed here: an unexpected ordering of the entries on the grub boot menu (Kathryn), vs the wrong entry being marked as the default (Jan, Thomas, and me too).  Can someone clarify whether these are different symptoms of the same underlying problem in grubby, or should these be tracked as two separate bugs?
Comment 32 Radosław Piliszek 2017-02-16 03:59:57 EST
Related bug (not about ordering): https://bugzilla.redhat.com/show_bug.cgi?id=1367792#c8
Comment 35 rmarshall 2017-03-07 15:02:36 EST
*** Bug 1398811 has been marked as a duplicate of this bug. ***
Comment 37 errata-xmlrpc 2017-08-01 14:47:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2042

Note You need to log in before you can comment on or make changes to this bug.