Bug 1285607 - Initramfs regeneration failed during run command "ovirt-node-rebuild-initramfs"
Initramfs regeneration failed during run command "ovirt-node-rebuild-initramfs"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ovirt-3.6.1
: ---
Assigned To: Fabian Deutsch
cshao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 22:35 EST by cshao
Modified: 2016-03-09 09:44 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-3.6.0-0.22.20151126git72acbb2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:44:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/*.* + sosreport (6.70 MB, application/x-gzip)
2015-11-25 22:35 EST, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49219 master MERGED mount_liveos: Check a few more places, don't break to much Never
oVirt gerrit 49263 ovirt-3.6 MERGED mount_liveos: Check a few more places, don't break to much Never

  None (edit)
Description cshao 2015-11-25 22:35:33 EST
Created attachment 1099091 [details]
/var/log/*.* + sosreport

Description of problem:
Initramfs regeneration failed during run command "ovirt-node-rebuild-initramfs"

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151112.1.el7ev)
# 
# ovirt-node-rebuild-initramfs
INFO - Preparing to regenerate the initramfs
INFO - The regenreation will overwrite the existing
INFO - Rebuilding for kver: 3.10.0-327.el7.x86_64
INFO - Mounting '/liveos' to /boot
ERROR - Initramfs regeneration failed
Traceback (most recent call last):
  File "/sbin/ovirt-node-rebuild-initramfs", line 35, in <module>
    initramfs.rebuild(kver)
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/system.py", line 1403, in rebuild
    with mounted_boot(source=self.boot_source):
  File "/usr/lib64/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/system.py", line 374, in mounted_boot
    raise RuntimeError("Failed to mount /liveos")
RuntimeError: Failed to mount /liveos
# 


Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H 7.2
2. Press F2 key to drop to shell
3. Run command "ovirt-node-rebuild-initramfs" to regenerate the initramfs.

Actual results:
Initramfs regeneration failed during run command "ovirt-node-rebuild-initramfs"

Expected results:
"ovirt-node-rebuild-initramfs" can work well.

Additional info:
Comment 1 Fabian Deutsch 2015-11-26 04:52:22 EST
Is this 100% reproducible?

I can not reproduce it locally.
Comment 3 Fabian Deutsch 2015-11-26 06:47:18 EST
Another patch was needed for machines like the machine where it failed in comment 0
Comment 5 cshao 2015-12-14 05:09:10 EST
Test version:
rhev-hypervisor7-7.2-20151210.1
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch


Test steps:
1. Install RHEV-H7.2
2. Run command: 
# ovirt-node-rebuild-initramfs
INFO - Preparing to regenerate the initramfs
INFO - The regenreation will overwrite the existing
INFO - Rebuilding for kver: 3.10.0-327.3.1.el7.x86_64
INFO - Mounting '/liveos' to /boot
INFO - Generating new initramfs '/var/tmp/initrd0.img.new' for kver 3.10.0-327.3.1.el7.x86_64 (this can take a while)
INFO - Installing the new initramfs '/var/tmp/initrd0.img.new' to '/boot/initrd0.img'
INFO - Successfully unmounted /liveos and /boot
INFO - Initramfs regenration completed successfully

Test result:
Initramfs regenration completed successfully.

So the bug is fixed, change bug status to VERIFIED.
Comment 7 errata-xmlrpc 2016-03-09 09:44:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.