Bug 1285612 - UI error while sorting container nodes on Operating System, Kernel Version
UI error while sorting container nodes on Operating System, Kernel Version
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Yaacov Zamir
Tony
ui:container
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 23:04 EST by Nandini Chandra
Modified: 2016-06-29 11:11 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:11:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-11-25 23:04:44 EST
Description of problem:
-----------------------
The UI blows up with this error while sorting container nodes on Operating System and Kernel Version.

Error text:
ERROR: column container_nodes.system_distribution does not exist LINE 1: ...tems"."id" = "container_nodes"."ems_id" ORDER BY container_... ^ [container_node/show_list] 

Snippet from production.log:
[----] I, [2015-11-25T22:58:40.684342 #14439:1133994]  INFO -- : Started POST "/container_node/show_list?sortby=4&" for 127.0.0.1 at 2015-11-25 22:58:40 -0500
[----] I, [2015-11-25T22:58:42.004539 #14439:1133994]  INFO -- : Processing by ContainerNodeController#show_list as JS
[----] I, [2015-11-25T22:58:42.004651 #14439:1133994]  INFO -- :   Parameters: {"sortby"=>"4"}
[----] F, [2015-11-25T22:58:48.000915 #14439:1133994] FATAL -- : Error caught: [PG::UndefinedColumn] ERROR:  column container_nodes.system_distribution does not exist
LINE 1: ...tems"."id" = "container_nodes"."ems_id"  ORDER BY container_...
                                                             ^

/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/postgresql_adapter.rb:592:in `async_exec'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/postgresql_adapter.rb:592:in `block in exec_no_cache'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract_adapter.rb:472:in `block in log'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract_adapter.rb:466:in `log'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/postgresql_adapter.rb:592:in `exec_no_cache'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/postgresql_adapter.rb:584:in `execute_and_clear'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/postgresql/database_statements.rb:160:in `exec_query'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract/database_statements.rb:355:in `select'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract/database_statements.rb:32:in `select_all'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract/query_cache.rb:68:in `block in select_all'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract/query_cache.rb:83:in `cache_sql'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/connection_adapters/abstract/query_cache.rb:68:in `select_all'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation/finder_methods.rb:356:in `find_with_associations'
/var/www/miq/vmdb/lib/extensions/ar_virtual.rb:374:in `find_with_associations_with_virtual'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation.rb:639:in `exec_queries'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation.rb:515:in `load'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation.rb:243:in `to_a'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:355:in `build_table'
/var/www/miq/vmdb/app/models/miq_report/search.rb:125:in `paged_view_search'
/var/www/miq/vmdb/app/controllers/application_controller.rb:1756:in `get_view'
/var/www/miq/vmdb/app/controllers/application_controller/ci_processing.rb:999:in `process_show_list'
/var/www/miq/vmdb/app/controllers/container_node_controller.rb:10:in `show_list'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:198:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rendering.rb:10:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:555:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:92:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:778:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rescue.rb:29:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/params_wrapper.rb:250:in `process_action'



Version-Release number of selected component (if applicable):
--------------------
5.5.0.12



How reproducible:
----------------
Always


Steps to Reproduce:
------------------
1.Manager a Container 
2.Navigate to Containers -> Container Nodes page
3.Sort container nodes on Operating System, Kernel Version


Actual results:
---------------
UI error


Expected results:
----------------
No UI error


Additional info:
----------------
Comment 2 Federico Simoncelli 2016-03-21 12:41:09 EDT
Kobi, can you look at this? Thank you.
Comment 3 Yaacov Zamir 2016-03-21 13:45:30 EDT
Submited upstream:
https://github.com/ManageIQ/manageiq/pull/7441
Comment 4 Federico Simoncelli 2016-05-12 17:43:15 EDT
Yaacov, shouldn't this be moved to POST?
Comment 6 errata-xmlrpc 2016-06-29 11:11:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.