Bug 1285614 - ckermit FTBFS on aarch64 epel7
Summary: ckermit FTBFS on aarch64 epel7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils
Version: 7.2
Hardware: aarch64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Nick Clifton
QA Contact: Miloš Prchlík
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64 1297579 1313485 1277314
TreeView+ depends on / blocked
 
Reported: 2015-11-26 04:20 UTC by Yaakov Selkowitz
Modified: 2016-11-04 01:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A bug in the linker meant that it was unable to link some AArch64 binaries. Consequence: Some AArch64 programs could not be linked. Fix: Rebase the binutils to the 2.25.1 release which includes a fix for this problem. Result: No more problems linking AArch64 binaries.
Clone Of:
Environment:
Last Closed: 2016-11-04 01:53:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2265 normal SHIPPED_LIVE binutils bug fix update 2016-11-03 13:33:42 UTC

Description Yaakov Selkowitz 2015-11-26 04:20:38 UTC
Attempting to build ckermit from Fedora EPEL on RHELSA 7.2 ends with the following error:

http://download.eng.bos.redhat.com/brewroot/work/tasks/411/10150411/build.log

ckcpro.o: In function `wart':
/builddir/build/BUILD/ckermit-9.0.302/ckcpro.c:1510:(.text+0x3080): relocation truncated to fit: R_AARCH64_LDST64_ABS_LO12_NC against symbol `dest' defined in .bss section in ckcmai.o
collect2: error: ld returned 1 exit status

Note that this package builds correctly on F23, but not F22 or earlier either (with the same error).  Apparently there is a fix in more recent toolchain that we are missing in 7.2.

Comment 2 Nick Clifton 2016-01-29 11:30:48 UTC
The new 7.3 binutils is based upon the F23 binutils, so changing this BZ to MODIFIED so that QE can test/verify.

Comment 5 Miloš Prchlík 2016-06-27 12:14:36 UTC
Verified for build binutils-2.25.1-20.base.el7 - ld refuses to link the binary - which the expected behavior, as per https://bugzilla.redhat.com/show_bug.cgi?id=1300543#c3 - but provides more descriptive message.

Comment 9 errata-xmlrpc 2016-11-04 01:53:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2265.html


Note You need to log in before you can comment on or make changes to this bug.