Bug 1285625 - fops-during-migration.t fails if hot and cold tiers are dist-rep
fops-during-migration.t fails if hot and cold tiers are dist-rep
Status: CLOSED DUPLICATE of bug 1285783
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.1
All All
high Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
storage-qa-internal@redhat.com
: Triaged, ZStream
Depends On: 1284823 1285783 1293827
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 00:23 EST by Nithya Balachandran
Modified: 2015-12-23 03:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284823
Environment:
Last Closed: 2015-11-30 00:18:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-11-26 00:23:12 EST
+++ This bug was initially created as a clone of Bug #1284823 +++

Description of problem:

tests/basic/tier/fop-during-migration.t was written using pure distribute hot and cold tiers
If the test is modified to have dist-rep cold and hot tiers, the following operation fails with EINVAL:

echo $TEST_STR > $M0/dir1/FILE1



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Modify tests/basic/tier/fop-during-migration.t to use dist-rep tiers
2. run tests/basic/tier/fop-during-migration.t
3.

Actual results:

Fails with EINVAL

Expected results:

The test should pass.

Additional info:

--- Additional comment from Nithya Balachandran on 2015-11-24 04:58:28 EST ---

Analysis:

echo $TEST_STR > $M0/dir1/FILE1

performs an ftruncate operation.

Investigation reveals that when a file is being migrated by the tier layer, the redirection of the ftruncate FOP to the dst subvol fails as posix_ftruncate fails in sys_ftruncate with op_errno EINVAL. This is because the fd being used has flags=0.

AFR calls afr_fix_open() to open the fd on the dst subvol but ends up using flags = 0 (instead of using the required flags). This causes the ftruncate to fail with EINVAL.

--- Additional comment from Vijay Bellur on 2015-11-25 10:50:27 EST ---

REVIEW: http://review.gluster.org/12750 (cluster/dht : Ftruncate on migrating file fails with EINVAL) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 2 Nithya Balachandran 2015-11-30 00:18:28 EST

*** This bug has been marked as a duplicate of bug 1285783 ***

Note You need to log in before you can comment on or make changes to this bug.