Bug 1285649 - Upgrade MonoDevelop to 5.10, Cycle 6
Upgrade MonoDevelop to 5.10, Cycle 6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Timotheus Pokorra
Fedora Extras Quality Assurance
:
Depends On: newtonsoft-json
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 02:38 EST by Timotheus Pokorra
Modified: 2016-02-11 07:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 07:31:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timotheus Pokorra 2015-11-26 02:38:21 EST
current version is 5.9.

We should build 5.10 for rawhide.

there are a couple of issues, we need to disable nuget collecting packages, and need to provide those packages via build requirements.
Comment 1 Timotheus Pokorra 2015-11-26 02:39:39 EST
we need Newtonsoft.Json to build monodevelop 5.10
Comment 2 Raphael Groner 2015-11-26 05:28:53 EST
As already suggested in bug #1187311 we need MonoDevelop 5.10 to get rid of that nasty upstream/legacy bug: https://bugzilla.xamarin.com/show_bug.cgi?id=32162
Comment 3 Raphael Groner 2015-11-26 05:36:44 EST
(In reply to Timotheus Pokorra from comment #1)
> we need Newtonsoft.Json to build monodevelop 5.10

Maybe you can disable the requiring test for now. This needs commonly a patch to exclude the file from the dedicated csproj file which builds the tests.
Comment 4 Raphael Groner 2016-02-11 07:31:34 EST
I'm closing here cause monodevelop 5.10 is in rawhide since over a month. Please feel free to reopen if there's still any issue.

Note You need to log in before you can comment on or make changes to this bug.