Bug 1285669 - DELETE on interface deletes entire host
DELETE on interface deletes entire host
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity high (vote)
: 6.2.11
: --
Assigned To: satellite6-bugs
jcallaha
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 03:43 EST by David Juran
Modified: 2017-08-10 13:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 13:02:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2466 normal SHIPPED_LIVE Satellite 6.2.11 Async Release 2017-08-10 17:01:20 EDT

  None (edit)
Description David Juran 2015-11-26 03:43:19 EST
Description of problem:
Through the API, I issued a DELETE on https://10.0.50.1/api/v2/hosts/52/interfaces/188 and the entire host got deleted

Version-Release number of selected component (if applicable):
Satellite 6.1.3

Additional info:
The interface was not a primary one, in fact it was a VLAN ontop of a bonded interface
Comment 1 Bryan Kearney 2016-07-26 15:09:33 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 6 Marek Hulan 2017-07-19 04:49:28 EDT
The tests seems to exist, I can not reproduce this on Sat 6.2. Can we just move it to ON_QA and rely on automation to verify it?
Comment 11 jcallaha 2017-07-20 10:31:31 EDT
Verified by automation in Satellite 6.2.11 Snap 1.
Comment 13 errata-xmlrpc 2017-08-10 13:02:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2466

Note You need to log in before you can comment on or make changes to this bug.