Bug 1285698 - Openning attachments opens sometimes reply window
Openning attachments opens sometimes reply window
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 04:58 EST by Artur Flinta
Modified: 2015-11-26 09:46 EST (History)
4 users (show)

See Also:
Fixed In Version: evolution-3.18.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 09:46:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artur Flinta 2015-11-26 04:58:11 EST
Description of problem:

When I receive message with multiple attachments, then when I double click on attachment (from list under message header), then sometimes reply window opens beside attachment file. When I double click on other attachment I can see that evolution starts selecting different parts of message header. More double clicked attachments, more parts of message header is selected and more likely that reply window will appear.

Version-Release number of selected component (if applicable):
I've observed this „feature” from Fedora 22 days, but it's still present on evolution 3.18.2.

How reproducible:
Mostly always.

Steps to Reproduce:
1. Receive any message with multiple PDF attachments 
2. Double click on first attachment from list above message body, and then on others. 
3. Observe that evolution starts selecting different parts of message header (above attachment list) and sometimes opens extra reply window.

Actual results:
Open attachment with selecting parts of message header and sometimes opens extra reply window.

Expected results:
Open attachment without opening reply window or selecting parts of message header.

Additional info:
I'm using this on exchange account (same behavior with Exchange 2007 and 2012).
Comment 1 Milan Crha 2015-11-26 08:03:31 EST
Thanks for a bug report. I tried to reproduce it, but I failed at the beginning. I realized that it depends what view you use for the attachment bar. Using the icon (default) view, I wasn't able to reproduce it, but when I switched to the list view, it begun to do the tricks. It looks like the double-click is interpreted twice, once in the list view, the other time in the message preview. That's why the double-click changes selection in the preview.

I also managed to open the composer with the double-click, but it wasn't a reply, it was a fresh new message to an address which was under the double-clicked area in the message preview (reply quotes the original message, fills Subject and other headers, which this new message didn't have set).
Comment 2 Artur Flinta 2015-11-26 08:07:17 EST
Yes, you are right it is blank compose window (no filled recipient addresses nor message inside).
Comment 3 Milan Crha 2015-11-26 09:46:45 EST
I figured the reason and made changes upstream to fix it with the below commits. The commit message contains an explanation. Current workaround is to use Icon View, instead of the List View.

Created commit 2a866a0 in evo master (3.19.3+) [1]
Created commit 38ac359 in evo gnome-3-18 (3.18.3+)

[1] https://git.gnome.org/browse/evolution/commit/?id=2a866a0

Note You need to log in before you can comment on or make changes to this bug.