Bug 1285708 - Google address book access fails due to ClientLogin being phased out
Google address book access fails due to ClientLogin being phased out
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Milan Crha
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 05:28 EST by Grega Bremec
Modified: 2015-11-26 05:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 05:46:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grega Bremec 2015-11-26 05:28:33 EST
Description of problem:

Upon trying to access a Google address book, I get the following error:

"This address book cannot be opened.  This either means that an incorrect URI was entered, or the server is unreachable."

"Detailed error message: Unable to connect to 'Contacts': The requested resource was not found: https://developers.google.com/accounts/docs/AuthForInstalledApps"

Version-Release number of selected component (if applicable):
evolution-data-server-3.12.11-24.el7.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Add a Google address book (or create a Google account in Evolution)
2. Try to access the contents

Actual results:
The above error.

Expected results:
The contents of the Google address book.

Additional info:
The above URL displays the error background from Google - apparently, they have migrated to OAuth 2.0 a while ago.
Comment 1 Milan Crha 2015-11-26 05:46:13 EST
Thanks fro a bug report. That's a known issue since the Google server disabled the ClientLogin. The current "workaround" is to setup the Google account in GNOME Online Accounts (gnome-control-center->Online Accounts), which uses OAuth and thus works as expected. The upcoming upstream stable version 3.20.0 will allow added Google accounts with OAuth authentication directly in the evolution.

Note You need to log in before you can comment on or make changes to this bug.