Bug 1285718 - New puppet modules to add in the openstack-puppet-modules packages.
New puppet modules to add in the openstack-puppet-modules packages.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Martin Magr
Udi
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 05:32 EST by Jaume Devesa
Modified: 2016-04-07 17:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.2-1.el7ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:14:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaume Devesa 2015-11-26 05:32:40 EST
The following puppet modules with the following versions have been added on puppet-tripleo:

'midonet':
  repo: 'git://github.com/midonet/puppet-midonet.git'
  ref: 'v2015.06.7'
'tomcat':
  repo: 'git://github.com/puppetlabs/puppetlabs-tomcat.git'
  ref: '1.3.2'
'inifile':
  repo: 'git://github.com/puppetlabs/puppetlabs-inifile.git'
  ref: '1.4.2'
'cassandra':
  repo: 'git://github.com/midonet/puppet-cassandra.git'
  ref: 'v1.1.1'
'zookeeper':
  repo: 'git://github.com/deric/puppet-zookeeper.git'
  ref: 'v0.3.9'
'datacat':
  repo: 'git://github.com/richardc/puppet-datacat'
  ref: '0.6.2'
'java':
  repo: 'git://github.com/puppetlabs/puppetlabs-java'
  ref: '1.4.2'


Can they be added on the openstack-puppet-modules package?
Comment 1 Martin Magr 2015-11-26 09:30:48 EST
After investigation, there are some notes:

- puppetlabs-inifile
    - module is already in OPM
- puppetlabs-cassandra 
    - creates conflict with our currently used cassandra 
      module (https://github.com/locp/cassandra.git)
    - question is in which installer the module is used.
      It definitely is not in Packstack [1], neither in OFI [2],
      neither in THT [3] and neither in Spinalstack [4]
    - from my point of view switching for puppetlabs-cassandra is safe,
      any other opinion?
- puppet-zookeeper
    - creates conflict with our currently used zookeeper module
      (https://github.com/miguno/puppet-zookeeper.git)
    - same as for cassandra, switch is IMHO safe according to [5][6][7][8]

For the rest of the modules I've created midstream patch:
https://review.gerrithub.io/253451

[1] https://github.com/openstack/packstack/search?utf8=%E2%9C%93&q=cassandra
[2] https://github.com/redhat-openstack/astapor/search?utf8=%E2%9C%93&q=cassandra
[3] https://github.com/openstack/tripleo-heat-templates/search?utf8=%E2%9C%93&q=cassandra
[4] https://github.com/stackforge/puppet-openstack-cloud/search?utf8=%E2%9C%93&q=cassandra
[5] https://github.com/redhat-openstack/astapor/search?utf8=%E2%9C%93&q=zookeeper&type=Code
[6] https://github.com/openstack/tripleo-heat-templates/search?utf8=%E2%9C%93&q=zookeeper&type=Code
[7] https://github.com/stackforge/puppet-openstack-cloud/search?utf8=%E2%9C%93&q=zookeeper&type=Code
[8] https://github.com/openstack/packstack/search?utf8=%E2%9C%93&q=zookeeper
Comment 2 Emilien Macchi 2015-11-26 09:32:27 EST
+1 for switching to new puppetlabs-cassandra and puppet-zookeeper
Comment 3 Jaume Devesa 2015-11-26 09:46:40 EST
We'll try to adapt puppet-midonet to these puppet-zookeeper and puppet-cassandra modules.
Comment 4 Martin Magr 2015-11-30 06:21:34 EST
Zookeper switch: https://review.gerrithub.io/#/c/253670/
Comment 5 Jaume Devesa 2015-11-30 09:06:17 EST
After a chat in #rdo-puppet IRC with Martin, we decide to switch the zookeeper one to deric/pupet-zookeeper[1] since no installer uses the miguno/puppet-zookeeper, and maintain the locp/puppet-cassandra since it is much better and more complete module than the midonet/puppet-cassandra one.

[1]: https://github.com/deric/puppet-zookeeper
[2]: https://github.com/locp/cassandra
[3]: https://github.com/midonet/
Comment 6 Jaume Devesa 2015-12-09 11:32:48 EST
Hi, I understand that these changes will be applied to delorean packages as well, right?
Comment 7 Jason Guiditta 2015-12-16 15:35:56 EST
Martin, I see your two reviews are against master for gerrithub.  In order to pull these into a liberty/osp8 release, we need to pull those into a review for upstream-liberty, don't we?
Comment 8 Martin Magr 2015-12-17 05:48:21 EST
Yes, but all patches for this bug were merged before branching liberty and indeed I see them both in upstream-liberty and stable/liberty from Dec 1:

https://github.com/redhat-openstack/openstack-puppet-modules/commits/upstream-liberty
https://github.com/redhat-openstack/openstack-puppet-modules/commits/stable/liberty
Comment 10 Udi 2016-01-19 05:06:47 EST
The puppets were added to the package. Verified in openstack-puppet-modules-7.0.3-1.el7ost.noarch.
Comment 11 errata-xmlrpc 2016-04-07 17:14:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.