Bug 1285743 - Test RHEV manager upgrade path from RHEL 6 with RHEL 7
Test RHEV manager upgrade path from RHEL 6 with RHEL 7
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-4.0.0-alpha
: ---
Assigned To: Sandro Bonazzola
Jiri Belka
: TestOnly
Depends On: 1234257
Blocks: 1258838
  Show dependency treegraph
 
Reported: 2015-11-26 06:33 EST by Yaniv Lavi (Dary)
Modified: 2016-03-11 01:48 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1234257
Environment:
Last Closed: 2016-03-11 01:48:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Lavi (Dary) 2015-11-26 06:33:00 EST
+++ This bug was initially created as a clone of Bug #1234257 +++

+++ This bug was initially created as a clone of Bug #1131828 +++

Need to fix track and add issues to RHEL on this upgrade flow to make it work.


--- Additional comment from Sandro Bonazzola on 2015-10-05 12:52:33 IDT ---

installed a clean minimal CentOS 6.7.

yum distro-sync

installed ovirt-release35.noarch 0:005-1
installed ovirt-engine.noarch 0:3.5.4.2-1.el6


          --== CONFIGURATION PREVIEW ==--

          Application mode                        : both
          Firewall manager                        : iptables
          Update Firewall                         : True
          Host FQDN                               : mididell.home
          Engine database name                    : engine
          Engine database secured connection      : False
          Engine database host                    : localhost
          Engine database user name               : engine
          Engine database host name validation    : False
          Engine database port                    : 5432
          Engine installation                     : True
          NFS setup                               : True
          PKI organization                        : home
          NFS mount point                         : /var/lib/exports/iso
          NFS export ACL                          : mididell.home(rw)
          Configure local Engine database         : True
          Set application as default page         : True
          Configure Apache SSL                    : True
          Configure WebSocket Proxy               : True
          Engine Host FQDN                        : mididell.home

          Please confirm installation settings (OK, Cancel) [OK]:

connected to mididell.home:
 Welcome to Open Virtualization Manager Version 3.5.4.2-1.el6


Before starting the upgrade be sure to have a backup!

Follow: https://wiki.centos.org/TipsAndTricks/CentOSUpgradeTool

# cat >/etc/yum.repos.d/upgradetool.repo <<EOF
> [upg]
> name=CentOS-$releasever - Upgrade Tool
> baseurl=http://dev.centos.org/centos/6/upg/x86_64/
> gpgcheck=1
> enabled=1
> gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
> EOF

# yum install redhat-upgrade-tool preupgrade-assistant-contents

# preupg -l
CentOS6_7

# preupg -s CentOS6_7
Preupg tool doesn't do the actual upgrade.
Please ensure you have backed up your system and/or data in the event of a failed upgrade
 that would require a full re-install of the system from installation media.
Do you want to continue? y/n y


It found several issues on my system. Of the required HIGH risk issues, the only one I can handle before the upgrade is selinux

# selinux -r sandbox
# rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-7
# centos-upgrade-tool-cli --network 7 --instrepo=http://mirror.centos.org/centos/7/os/x86_64/


Preupgrade assistant risk check found risks for this upgrade.
You can run preupg --riskcheck --verbose to view these risks.
Addressing high risk issues is required before the in-place upgrade
and ignoring these risks may result in a broken upgrade and unsupported upgrade.
Please backup your data.

List of issues:
INPLACERISK: HIGH: We detected some non-CentOS signed packages, you can find the list in /root/preupgrade/./kickstart/noncentospkgs. You need to handle them yourself!
INPLACERISK: HIGH: Package python-cheetah  (required by NonCentOS signed package(s):ovirt-engine-backend ) removed between CentOS 6 and CentOS 7
INPLACERISK: HIGH: Package python-paramiko  (required by NonCentOS signed package(s):ovirt-engine-setup-base ) removed between CentOS 6 and CentOS 7
INPLACERISK: HIGH: After upgrading to CentOS 7 there are still some el6 packages left. Add --cleanup-post option to redhat-upgrade-tool if you want to remove them automatically.
INPLACERISK: HIGH: There were changes in SELinux policies between CentOS 6 and CentOS 7. Please, check solution in order to resolve this issue.
INPLACERISK: HIGH: Library postgresql-server (required by NonCentOS signed package(s):ovirt-engine ) removed between CentOS 6 and CentOS 7
INPLACERISK: HIGH: Library postgresql-server (required by NonCentOS signed package(s):ovirt-engine ) removed between CentOS 6 and CentOS 7
INPLACERISK: HIGH: The service blk-availability on CentOS 7 is disabled by default. Enable them via commands: systemctl enable blk-availability && systemctl start blk-availability.service .
INPLACERISK: HIGH: The service httpd on CentOS 7 is disabled by default. Enable them via commands: systemctl enable httpd && systemctl start httpd.service .
INPLACERISK: HIGH: The service ip6tables on CentOS 7 is disabled by default. Enable them via commands: systemctl enable ip6tables && systemctl start ip6tables.service .
INPLACERISK: HIGH: The service iscsi on CentOS 7 is disabled by default. Enable them via commands: systemctl enable iscsi && systemctl start iscsi.service .
INPLACERISK: HIGH: The service iscsid on CentOS 7 is disabled by default. Enable them via commands: systemctl enable iscsid && systemctl start iscsid.service .
INPLACERISK: HIGH: The service messagebus on CentOS 7 is disabled by default. Enable them via commands: systemctl enable messagebus && systemctl start messagebus.service .
INPLACERISK: HIGH: The service netfs on CentOS 7 is disabled by default. Enable them via commands: systemctl enable netfs && systemctl start netfs.service .
INPLACERISK: HIGH: The service network on CentOS 7 is disabled by default. Enable them via commands: systemctl enable network && systemctl start network.service .
INPLACERISK: HIGH: The service nfs on CentOS 7 is disabled by default. Enable them via commands: systemctl enable nfs && systemctl start nfs.service .
INPLACERISK: HIGH: The service nfslock on CentOS 7 is disabled by default. Enable them via commands: systemctl enable nfslock && systemctl start nfslock.service .
INPLACERISK: HIGH: The service postfix on CentOS 7 is disabled by default. Enable them via commands: systemctl enable postfix && systemctl start postfix.service .
INPLACERISK: HIGH: The service postgresql on CentOS 7 is disabled by default. Enable them via commands: systemctl enable postgresql && systemctl start postgresql.service .
INPLACERISK: HIGH: The service rpcgssd on CentOS 7 is disabled by default. Enable them via commands: systemctl enable rpcgssd && systemctl start rpcgssd.service .
INPLACERISK: HIGH: The service udev-post on CentOS 7 is disabled by default. Enable them via commands: systemctl enable udev-post && systemctl start udev-post.service .
INPLACERISK: HIGH: additional libcgroup configuration files were created (/etc/cgconfig.d)
INPLACERISK: MEDIUM: We detected some packages installed on the system were removed (obsoleted) between CentOS 6 and CentOS 7. This may break the functionality of the packages depending on them.
INPLACERISK: MEDIUM: We detected some packages installed on the system were removed between CentOS 6 and CentOS 7. This may break the functionality of the packages depending on them.
INPLACERISK: MEDIUM: Package coreutils-libs not provided by its replacement coreutils. In-place upgrade might not work properly, will be finished by postupgrade script!
INPLACERISK: MEDIUM: Package libudev not provided by its replacement systemd-libs. In-place upgrade might not work properly, will be finished by postupgrade script!
INPLACERISK: MEDIUM: having one of [elfutils nss-tools tzdata-java elfutils-libelf libX11-common ca-certificates libX11 java-1.6.0-openjdk gtk2 device-mapper-multipath-libs libdrm device-mapper-multipath audit elfutils-libs nss-util nss java-1.7.0-openjdk openscap openldap audit-libs nspr audit-libs-python libpciaccess libxcb pixman kpartx mdadm tzdata nss-sysinit] package installed breaks upgrade
INPLACERISK: MEDIUM: a number of default configuation settings have changed in CentOS7. Users should verify that their devices are still optimally configured
INPLACERISK: MEDIUM:  We detected some soname bumps in the libraries installed on the system. This may break the functionality of some of your 3rd party applications. They may need rebuild. Please check their requirements.
INPLACERISK: MEDIUM:  We detected some .so libraries installed on the system were removed between CentOS 6 and CentOS 7. This may break the functionality of some of your 3rd party applications.
INPLACERISK: MEDIUM: The service ovirt-engine is not installed by CentOS signed packages and will not be automatically enabled after in-place upgrade.
INPLACERISK: MEDIUM: The service ovirt-fence-kdump-listener is not installed by CentOS signed packages and will not be automatically enabled after in-place upgrade.
INPLACERISK: MEDIUM: The service ovirt-websocket-proxy is not installed by CentOS signed packages and will not be automatically enabled after in-place upgrade.
INPLACERISK: MEDIUM: The service ovirt-engine-notifier is disabled and not installed by CentOS signed packages. It will be disabled after an in-place upgrade.
INPLACERISK: SLIGHT: We detected some files where modifications are not tracked in the rpms. You may need to check their functionality after successful upgrade.
INPLACERISK: SLIGHT: We detected some files untracked by rpms. Some of these may need manual check/migration after redhat-upgrade-tool and/or can cause conflicts or troubles during the installation. Try to reduce unnecessary untracked files before running redhat-upgrade-tool.
INPLACERISK: SLIGHT: We can't tell for 100% that the system will be in-place upgradable
INPLACERISK: SLIGHT: Package jakarta-commons-logging  (required by NonCentOS signed package(s):otopi-java vdsm-jsonrpc-java ) replaced between CentOS 6 and CentOS 7
INPLACERISK: SLIGHT: Package jpackage-utils  (required by NonCentOS signed package(s):xalan-j2 xalan-j2 ovirt-engine ) replaced between CentOS 6 and CentOS 7
INPLACERISK: SLIGHT: We detected some packages installed on the system changed their name between CentOS 6 and CentOS 7. Although they should be compatible, monitoring after the update is recommended.
INPLACERISK: SLIGHT: export shell commands will be deleted from /etc/sysconfig/sshd
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/cli is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/daemon is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/kitchen is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/kitchen-1.1.1-py2.6.egg-info is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/otopi is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirt_engine is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirt_engine_sdk_python-3.5.4.0-py2.6.egg-info is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirt_host_deploy is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirt_image_uploader is not owned by any RPM package.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirt_iso_uploader is not owned by any RPM package.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirt_shell-3.5.0.6-py2.6.egg-info is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirtcli is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ovirtsdk is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/ply is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/python_daemon-1.5.2-py2.6.egg-info is owned by an RPM package that was not signed by CentOS.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/websockify is not owned by any RPM package.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/websockify-0.6.0-py2.6.egg-info is owned by an RPM package that was not signed by CentOS.
INPLACERISK: NONE: Custom selinux configuration has been saved and it will be restored by a postupgrade script after the system upgrade.
Continue with the upgrade [Y/N]? y


After reboot, the RPM packages have been upgraded. After the final reboot, the system doesn't boot anymore, issueing a kernel panic.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-10-19 14:02:16 IDT ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 1 Jiri Belka 2016-02-23 06:55:09 EST
d/s doesn't support engine on RHEL7 yet. and doesn't d/s support only RHELs anyway? IMO it should be 'CLOSED WONTFIX' until engine is supported on RHEL7.
Comment 2 Sandro Bonazzola 2016-02-26 02:00:39 EST
(In reply to Jiri Belka from comment #1)
> d/s doesn't support engine on RHEL7 yet. and doesn't d/s support only RHELs
> anyway? IMO it should be 'CLOSED WONTFIX' until engine is supported on RHEL7.

Jiri, this is for 4.0 and was cloned from upstream where el7 is already supported. In 4.0 engine will be on el7 as well so we need to test themigration path. moving back to new since we haven't built downstream packages for el7 testing.
Comment 3 Yaniv Kaul 2016-03-11 01:48:34 EST
Closing - we'll have a migration tool from EL6 based engine to EL7, but will not support in-place.

Note You need to log in before you can comment on or make changes to this bug.