Bug 1285747 - setuid bit testcase failing with tiering volume with nfs-ganesha
setuid bit testcase failing with tiering volume with nfs-ganesha
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Soumya Koduri
nchilaka
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 06:39 EST by Apeksha
Modified: 2016-09-17 11:39 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 00:53:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Apeksha 2015-11-26 06:39:03 EST
Description of problem:
setuid bit testcase failing with tireing volume with nfs-ganesha

Version-Release number of selected component (if applicable):
glusterfs-3.7.5-7.el7rhgs.x86_64
nfs-ganesha-gluster-2.2.0-11.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a tired volume
2. Mount it using nfs-ganesha vers=3
3. Create a file and change its permission to 600
4. Now edit the config file of the volume and set Root squash and run-refresh config
5. On the client - chmod u+s /bin/echo /bin/cat
6. write/read the file using /bin/echo and /bin/cat , it should fail but unexpectedly it allows.

The testcase passes for a non-tiered volume, read/write is not allowed for that file

Actual results:


Expected results:


Additional info:
Comment 3 nchilaka 2015-11-30 01:53:17 EST
the config file referred here is the ganesha config file, which is available in each volume under /etc/ganesha/exports/export.<vname>.conf
Comment 6 Apeksha 2015-12-02 00:53:46 EST
Not able to reproduce it again, ran my scripts couple of times. The setup was actually in a wiered state, looks like it was a configuration issue.

Note You need to log in before you can comment on or make changes to this bug.