Bug 1285761 - man page of 'modifyrepo' does not list any options
man page of 'modifyrepo' does not list any options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: createrepo (Show other bugs)
7.1
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Michal Domonkos
Eva Mrakova
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 07:02 EST by Stanislav Zidek
Modified: 2016-11-03 19:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: createrepo-0.9.9-26.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:56:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (2.55 KB, patch)
2016-02-03 08:00 EST, Michal Domonkos
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2173 normal SHIPPED_LIVE createrepo bug fix and enhancement update 2016-11-03 09:16:27 EDT

  None (edit)
Description Stanislav Zidek 2015-11-26 07:02:59 EST
Description of problem:
I am not sure if this is a intentional, but man page of modifyrepo does not contain the OPTIONS section and therefore does not list any parameters it supports. When comparing to RHEL-6, the man page is exactly the same + all the options listed in RHEL-6.

Version-Release number of selected component (if applicable):
createrepo-0.9.9-23.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. man modifyrepo

Actual results:
NAME
       modifyrepo - Modify a repomd (xml-rpm-metadata) repository


SYNOPSIS
       modifyrepo [options] <input metadata> <output repodata>

DESCRIPTION
       modifyrepo is a program that allows you to insert arbitrary metadata into a repomd (xml-based rpm metadata)
       repository.


EXAMPLES
       $ modifyrepo --mdtype=newmd metadata.xml /repository/repodata
       Wrote: /repository/repodata/metadata.xml.gz
                  type = newmd
              location = repodata/metadata.xml.gz
              checksum = 1d7ee93db2964e7f85e07ec19b3204591da1050c
             timestamp = 1196716296.0
         open-checksum = 824d936dc7dfff029379797b311af0cc66af4115
       Wrote: /repository/repodata/repomd.xml


SEE ALSO
       createrepo (8)


AUTHORS
       Luke Macken <lmacken@redhat.com>
       Seth Vidal <skvidal@fedoraproject.org>


BUGS
       Any bugs which are found should be emailed to the mailing list: rpm-metadata@lists.baseurl.org


Expected results:
OPTIONS section present
Comment 2 Michal Domonkos 2016-02-03 08:00 EST
Created attachment 1120778 [details]
patch
Comment 8 errata-xmlrpc 2016-11-03 19:56:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2173.html

Note You need to log in before you can comment on or make changes to this bug.