Bug 1285782 - JSON protocol should not be enabled on 3.5 host in 3.6 engine by default
JSON protocol should not be enabled on 3.5 host in 3.6 engine by default
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1
All All
unspecified Severity medium (vote)
: ovirt-3.6.2
: ---
Assigned To: Piotr Kliczewski
Lukas Svaty
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 07:52 EST by Lukas Svaty
Modified: 2016-02-10 14:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 07:23:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2015-11-26 07:52:52 EST
Description of problem:
When adding host to 3.5 cluster in 3.6 engine, by default is JsonRPC enabled, however as it was not default in 3.5 engine as is default in 3.6 engine it should be for admin a possibility not mandatory.

Version-Release number of selected component (if applicable):


How reproducible:
rhevm-webadmin-portal-3.6.1-0.2.el6.noarch

Steps to Reproduce:
1. Add new host
2. See Advanced tab

Actual results:
Use JSON protocol is checked

Expected results:
Should be unchecked by default

Additional info:
Comment 1 Oved Ourfali 2015-11-29 03:21:02 EST
As far as I know this is the default in 3.5 engine as well.
In 3.6 engine + 3.6 cluster, this is mandatory.
In 3.6 engine + 3.5 cluster, it should be the default.

I also think that even if it wasn't the default in 3.5 engine, it should be the default now. Moving to 3.6 cluster level will require you to have the communication to jsonrpc.

Is it really not the default to new 3.5 clusters in 3.5 engine?
Comment 2 Lukas Svaty 2015-11-30 05:18:18 EST
Currently:

Engine    Cluster    Status
3.5       3.4        Disabled
3.5       3.5        Enabled by deafult
3.6       3.5        Enabled by deafult
3.6       3.6        Mandatory


As you said this option is enabled by default on 3.5 as well.
If we want to push user to use JSON protocol pro-actively in 3.5 cluster this should be CLOSED as NOTABUG as it is intended design.
Comment 3 Oved Ourfali 2015-12-02 07:23:49 EST
Indeed.
Always good to make sure this is indeed the behavior, especially when we want to get rid of xmlrpc in 4.0.

Closing as NOTABUG.

Thanks!
Oved

Note You need to log in before you can comment on or make changes to this bug.