Bug 1285789 - Configuration files /usr/lib/systemd/system/pki-* are marked executable. Please remove executable permission bits.
Configuration files /usr/lib/systemd/system/pki-* are marked executable. Plea...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: 7.3
Assigned To: Matthew Harmsen
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 08:39 EST by Jan Pazdziora
Modified: 2016-11-04 01:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: pki-core-10.3.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:20:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-11-26 08:39:48 EST
Description of problem:

When running ipa-server-install, systemd complains about executable bits on unit files.

Version-Release number of selected component (if applicable):

pki-server-10.2.5-6.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. yum install ipa-server ipa-server-dns bind bind-dyndb-ldap
2. ipa-server-install
3. Check journal with journalctl

Actual results:

systemd[1]: Configuration file /usr/lib/systemd/system/pki-tomcatd.target is marked executable. Please remove executable permission bits. Proceeding anyway.
systemd[1]: Configuration file /lib/systemd/system/pki-tomcatd@.service is marked executable. Please remove executable permission bits. Proceeding anyway.
systemd[1]: Configuration file /usr/lib/systemd/system/pki-tomcatd-nuxwdog.target is marked executable. Please remove executable permission bits. Proceeding anyway.
systemd[1]: Configuration file /usr/lib/systemd/system/pki-tomcatd-nuxwdog@.service is marked executable. Please remove executable permission bits. Proceeding anyway.

Expected results:

No such messages.

Additional info:
Comment 1 Matthew Harmsen 2016-01-06 20:54:21 EST
Per discussions in the RHEL 7.3 Triage meeting of 01/06/2016: priority medium
Comment 2 Matthew Harmsen 2016-01-06 20:55:49 EST
Upstream ticket:
https://fedorahosted.org/pki/ticket/1723
Comment 3 Matthew Harmsen 2016-04-15 17:32:30 EDT
ftweedal pushed to master:
* 966b3e906b48fdb34cfe0f5bc9092b45bfc9067d
Comment 5 Roshni 2016-09-07 11:11:20 EDT
[root@bkr-hv03-guest15 ~]# rpm -qi pki-ca
Name        : pki-ca
Version     : 10.3.3
Release     : 8.el7
Architecture: noarch
Install Date: Wed 07 Sep 2016 10:09:17 AM EDT
Group       : System Environment/Daemons
Size        : 2430595
License     : GPLv2
Signature   : RSA/SHA256, Wed 31 Aug 2016 10:30:32 AM EDT, Key ID 938a80caf21541eb
Source RPM  : pki-core-10.3.3-8.el7.src.rpm
Build Date  : Tue 30 Aug 2016 03:23:27 PM EDT
Build Host  : ppc-015.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://pki.fedoraproject.org/
Summary     : Certificate System - Certificate Authority

[root@bkr-hv03-guest15 ~]# ls -lrt /usr/lib/systemd/system/pki-*
-rw-r--r--. 1 root root 144 Jun 21 13:55 /usr/lib/systemd/system/pki-tomcatd.target
-rw-r--r--. 1 root root 360 Jun 21 13:55 /usr/lib/systemd/system/pki-tomcatd@.service
-rw-r--r--. 1 root root 163 Jun 21 13:55 /usr/lib/systemd/system/pki-tomcatd-nuxwdog.target
-rw-r--r--. 1 root root 422 Jun 21 13:55 /usr/lib/systemd/system/pki-tomcatd-nuxwdog@.service
[root@bkr-hv03-guest15 ~]# journalctl | grep "please remove executable permission bits"
Comment 7 errata-xmlrpc 2016-11-04 01:20:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2396.html

Note You need to log in before you can comment on or make changes to this bug.