This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1285799 - [RFE] - Document hostdev_passthrough and VFIO features in RHEV administration guide.
[RFE] - Document hostdev_passthrough and VFIO features in RHEV administration...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.1
Unspecified Unspecified
high Severity high
: ovirt-3.6.4
: 3.6.1
Assigned To: Andrew Burden
rhev-docs@redhat.com
: FutureFeature
: 1247578 (view as bug list)
Depends On:
Blocks: 1154205 1172230 825045
  Show dependency treegraph
 
Reported: 2015-11-26 08:56 EST by Nisim Simsolo
Modified: 2016-03-16 10:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-16 10:17:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nisim Simsolo 2015-11-26 08:56:58 EST
Description of problem:
In order to use both hostdev_passthrough and VFIO features, there are some limitations and preparations that needs to be documented.
Limitations example: host BIOS must support Intel vt-d or AMD-vi and host kernel should be >= 3.6
Setup preparation example: IOMMU support should be enabled, host GPU vendor:device ids should be added to pci-stub and GPU driver should be blacklisted.

Also, webadmin procedure for these features and feature limitations should be documented in the admin guide.


Additional info:
oVirt feature page: http://www.ovirt.org/Features/hostdev_passthrough#GPU_passthrough
Comment 2 Lucy Bopf 2016-01-26 23:15:58 EST
Assigning to Andrew for review.
Comment 3 Lucy Bopf 2016-02-15 22:56:45 EST
*** Bug 1247578 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Burden 2016-02-24 21:50:24 EST
This is going to involve new topics in the VMM and Admin Guide to cover the new GUI elements, and an admonition to VM migration topics in the VMM guide (those marked with * are still wip)

VMM Guide:
New topics: 
New section - Host Devices (in Administrative Tasks)
-*Device Passthrough concept - link to hardware considerations art.
-*Additional requirements for GPU passthrough (probably concept + proc.)
-Adding a Host Device to a Virtual Machine
-Removing Host Devices from a Virtual Machine
-Pinning a Virtual Machine to Another Host

Admonition added to:
-Preventing Automatic Migration of a Virtual Machine

Admin Guide:
New topic:
-Viewing Host Devices

Also, partially related, notice that there's no docs bug to cover SR-IOV in the GUI so will raise one out of BZ#869804
Comment 6 Dayle Parker 2016-03-07 02:49:27 EST
Looks great - thank you! Changes have been merged, added Revision History entries to the Admin Guide and VMM Guide.

Note You need to log in before you can comment on or make changes to this bug.