Bug 1285810 - Dracut module 'dmsquash-live' depends on 'img-lib' in kernel scriplet
Dracut module 'dmsquash-live' depends on 'img-lib' in kernel scriplet
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: dracut-maint
Release Test Team
:
Depends On:
Blocks: 1289485 1313485
  Show dependency treegraph
 
Reported: 2015-11-26 09:09 EST by Lukas Zapletal
Modified: 2016-04-04 03:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 03:32:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2015-11-26 09:09:48 EST
Cannot build a live image using livecd-creatorr because of some dependency issues in kernel scriplet:

dracut module 'dmsquash-live' depends on 'img-lib', which can't be installed
dracut module 'dmsquash-live' cannot be found or installed.
mkinitrd failed
warning: %posttrans(kernel-3.10.0-327.el7.x86_64) scriptlet failed, exit status 1

This is regression, it was working in 7.1.
Comment 2 Harald Hoyer 2015-11-26 10:18:18 EST
img lib needs "tar gzip dd bash"
Comment 3 Lukas Zapletal 2015-11-27 08:22:26 EST
So do you think as a workaround I can add those in the package kickstart profile? Are you going to fix the dependencies of the package, so I can make temporary comment with link to this BZ report? Thanks!
Comment 4 Harald Hoyer 2015-11-30 05:05:37 EST
Upstream we already have a dracut-live subpackage, which requires "tar" and "gzip".

So, yes, I can change the requirements for dracut in 7.3.
Comment 5 Lukas Zapletal 2015-11-30 09:08:43 EST
For the record, the temporary fix implemented in

https://github.com/theforeman/foreman-discovery-image/pull/54
Comment 6 Lukas Zapletal 2015-11-30 10:01:21 EST
Ok I have added the following new packages in the kickstart:

%packages
tar
gzip
coreutils
bash

And I am still getting:

dracut module 'dmsquash-live' depends on 'img-lib', which can't be installed
dracut module 'dmsquash-live' cannot be found or installed.
mkinitrd failed
warning: %posttrans(kernel-3.10.0-327.el7.x86_64) scriptlet failed, exit status 1
Comment 8 Lukas Zapletal 2015-11-30 10:22:26 EST
Oooh we had "-tar" in our kickstart! Trying without this line.
Comment 9 Lukas Zapletal 2015-11-30 11:03:53 EST
Yep, that was it, sorry for the noise. Looks similar to https://bugzilla.redhat.com/show_bug.cgi?id=1182362
Comment 10 Mike McCune 2016-03-28 18:31:02 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 11 Lukas Zapletal 2016-04-04 03:32:35 EDT
I think this one can be closed.

Note You need to log in before you can comment on or make changes to this bug.