This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1285822 - postgresql init script return wrong exit code when pid file exist and database isn't running
postgresql init script return wrong exit code when pid file exist and databas...
Status: CLOSED DUPLICATE of bug 1214800
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: postgresql (Show other bugs)
6.8
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 09:50 EST by Jakub Prokes
Modified: 2015-11-26 09:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 09:51:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Prokes 2015-11-26 09:50:06 EST
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
postgresql-server-8.4.20-2.el6_6.x86_64
initscripts-9.03.49-1.el6.x86_64

How reproducible:

Steps to Reproduce:
1. echo "666666" > /var/lib/pgsql/data/postmaster.pid
2. service postgresql status
3. echo $?

Actual results:
3

Expected results:
1

Additional info:
Due to LSB, when pid file exist and service isn't running initscript should return '1'

http://www.rcramer.com/tech/linux/init_lsb.shtml
Comment 2 Jakub Prokes 2015-11-26 09:51:56 EST

*** This bug has been marked as a duplicate of bug 1214800 ***

Note You need to log in before you can comment on or make changes to this bug.