Bug 128585 - kernel has problem initializing NUMA on a TYAN K8W
kernel has problem initializing NUMA on a TYAN K8W
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-26 14:26 EDT by Josef Bacik
Modified: 2013-08-05 21:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:32:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2004-07-26 14:26:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
Tyan K8W system, 4GB memory, BIOS v2.02

RHEL 3 U2, kernel version 2.4.21-15.0.3.ELsmp

SRAT/NUMA is setup in the BIOS, but RHEL is unable to setup NUMA when
loading
the kernel.  I've attached the messages file to help.  See these lines:

Jul  8 13:24:31 testpig3 kernel: kernel direct mapping tables upto
10280000000 @ 8000-13000
Jul  8 13:24:31 testpig3 kernel: Scanning NUMA topology in Northbridge 24
Jul  8 13:24:31 testpig3 kernel: Node 0 MemBase 0000000000000000 Limit
000000017fffffff
Jul  8 13:24:31 testpig3 kernel: Node 1 MemBase 0000000180000000 Limit
000000027fffffff
Jul  8 13:24:31 testpig3 kernel: Node map not sorted 180000000,0
Jul  8 13:24:31 testpig3 kernel: No NUMA configuration found
Jul  8 13:24:31 testpig3 kernel: Faking a node at
0000000000000000-0000000280000000

I have tried numa=on at the boot prompt as a kernel option, but that
doesnt make a difference, since NUMA is running, it just seems like
its having a problem sorting.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Bootup the computer

Actual Results:  It boots up normally, but you get this nice message
in /var/log/messages

Expected Results:  It should say that it found a NUMA configuration
and it initialized normally.

Additional info:
Comment 1 Jim Paradis 2004-07-26 15:05:12 EDT
This looks suspiciously like another issue I've seen; will investigate.
Comment 2 Jim Paradis 2004-07-26 15:38:31 EDT
I checked, and this should be fixed in Update 3.  The node-detection
code has been modified to better identify and skip nonexistent node
table entries.
Comment 3 Josef Bacik 2004-07-26 16:05:00 EDT
Ok, is there a package in the beta channel that I can hand the
customer until the next release, or is it in the kernel package.  If
its in the kernel package I'll just tell him to wait till next release.
Comment 4 Jim Paradis 2004-07-26 17:16:30 EDT
It's a kernel fix.  Grab the kernel from the beta channel and give it
a try.
Comment 5 Ernie Petrides 2004-08-02 19:49:53 EDT
Jim closed this as being fixed in "next release", which would
normally refer to RHEL4.  But the bug is actually being fixed
in RHEL3 Update 3, and it was tracked in bugzilla #121708.

So I'm (re)closing this as a dup of the older bug.  -ernie


*** This bug has been marked as a duplicate of 121708 ***
Comment 6 John Flanagan 2004-09-02 00:32:09 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.