Bug 1285862 - KSane.cmake is broken
KSane.cmake is broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libksane (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ngo Than
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 12:57 EST by Orion Poplawski
Modified: 2016-11-04 00:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: libksane-4.10.5-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:06:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CMakeLists.txt (117 bytes, text/plain)
2015-11-27 11:17 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2015-11-26 12:57:33 EST
Description of problem:

find_package(KSane REQUIRED)

fails with:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
KSANE_INCLUDE_DIR

It appears it is not pointing to the correct include directory.

Version-Release number of selected component (if applicable):
libksane-devel-4.10.5-3.el7.x86_64
Comment 1 Ngo Than 2015-11-27 08:46:51 EST
(In reply to Orion Poplawski from comment #0)
> Description of problem:
> 
> find_package(KSane REQUIRED)
> 
> fails with:
> 
> CMake Error: The following variables are used in this project, but they are
> set to NOTFOUND.
> Please set them or make sure they are set and tested correctly in the CMake
> files:
> KSANE_INCLUDE_DIR
> 
> It appears it is not pointing to the correct include directory.
> 
> Version-Release number of selected component (if applicable):
> libksane-devel-4.10.5-3.el7.x86_64

could you please give a a reproduce for this issue?
thanks
Comment 2 Orion Poplawski 2015-11-27 11:17 EST
Created attachment 1099736 [details]
CMakeLists.txt

I discovered this by trying to build skanlite, so one option is to just try building that.  The attached CMakeLists.txt will reproduce the problem of KSANE_INCLUDE_DIR not being set.  It should get set to /usr/include/kde4, instead I get:

KSANE_INCLUDE_DIR = KSANE_INCLUDE_DIR-NOTFOUND

http://koji.fedoraproject.org/koji/taskinfo?taskID=11995367

It is fixed in libksane-4.14.3-1.el7 from Rex's kde4 for el7 copr.
Comment 3 Ngo Than 2015-11-27 11:36:19 EST
Orion, thanks your feedbacks!
Comment 9 errata-xmlrpc 2016-11-04 00:06:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2343.html

Note You need to log in before you can comment on or make changes to this bug.