Bug 1285864 - Incorrect title in PDF reports for Openshift pods
Incorrect title in PDF reports for Openshift pods
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Libor Pichler
Einat Pacifici
container:report
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 13:28 EST by Nandini Chandra
Modified: 2016-06-29 11:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:12:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pod summary report (66.50 KB, application/pdf)
2015-11-26 13:28 EST, Nandini Chandra
no flags Details

  None (edit)
Description Nandini Chandra 2015-11-26 13:28:14 EST
Created attachment 1099347 [details]
Pod summary report

Description of problem:
-----------------------
I downloaded a PDF report of the summary of an Openshift pod.The Title of the PDF report is:

ManageIQ/Providers/Kubernetes/Container Manager/Container Group "django-example-1-4wpkn"

The title should contain Openshift instead of Kubernetes.


Version-Release number of selected component (if applicable):
-------------------------
5.5.0.12


How reproducible:
-----------------
Always


Steps to Reproduce:
------------------
1.Manage an Openshift container.
2.Navigate to the summary page of a pod.
3.Download the summary report.


Actual results:
----------------


Expected results:
-----------------


Additional info:
----------------
Comment 5 CFME Bot 2016-03-18 09:00:36 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/115b2c77efd27bd10343af50cad9dcf6092e70f2

commit 115b2c77efd27bd10343af50cad9dcf6092e70f2
Author:     Libor Pichler <liborpichler@Libors-MacBook-Pro.local>
AuthorDate: Mon Jan 18 16:07:47 2016 +0100
Commit:     lpichler <lpichler@redhat.com>
CommitDate: Thu Jan 21 17:15:39 2016 +0100

    Remove 'ManageIQ' from title of pdf report of pod
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1285864

 config/locales/en.yml | 1 +
 1 file changed, 1 insertion(+)
Comment 7 Einat Pacifici 2016-05-15 07:17:12 EDT
Pod summary report now shows PODs in summary PDF.
Comment 9 errata-xmlrpc 2016-06-29 11:12:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.