Bug 128589 - adding exec on rhn_exception for web
Summary: adding exec on rhn_exception for web
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 128151
TreeView+ depends on / blocked
 
Reported: 2004-07-26 20:29 UTC by Shannon Hughes
Modified: 2007-10-24 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 13:09:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shannon Hughes 2004-07-26 20:29:11 UTC
Description of problem:


<pjones> can you do me a favor and file a bug asking for exec on
rhn_exception to be granted to web_dml_r ?
<pjones> (just because the dbchange system requires a bug ID...)

Comment 1 Shannon Hughes 2004-07-28 18:26:11 UTC
also need the following added to the rhn_exception tables for this to
work:

label, msg

webreg_duplicate, Registration number already registered
webreg_not_active, Registration number is not active
webreg_sync_error, Synchronization error with sync_registration_uber
webreg_invalid, Registration number is invalid
webreg_unknown_error, Unknown registration error


Comment 2 Bret McMillan 2004-08-05 21:35:34 UTC
according to pjones, ON_DEV.

Test Plan:

will be tested by successful runs of bz #128392 and #128396

Comment 3 Bret McMillan 2004-08-06 17:57:25 UTC
Not done:

rhnuser@webdev> select
web.web_api.register_product('fd78-b3a5-2489-87bf', 37586 08) from dual;
 
ORA-20001: Unable to lookup exception with label (webreg_invalid)
ORA-06512: at "RHN.RHN_EXCEPTION", line 31
ORA-06512: at "WEB.WEB_API", line 70


Comment 4 Bret McMillan 2004-08-06 18:02:18 UTC
rhnuser@webdev> select id, label from rhnexception where label like
'web%';
 
0 rows selected (0.01 seconds)

So, we're missing all of these.

Comment 5 Peter Jones 2004-08-06 19:08:04 UTC
Exceptions are on dev now, sorry.

Comment 6 Fanny Augustin 2004-08-12 16:35:18 UTC
Looks good on Dev

Comment 7 Fanny Augustin 2004-08-12 19:52:33 UTC
Looks good on QA.


Note You need to log in before you can comment on or make changes to this bug.