Bug 1285894 - SELinux is preventing /usr/lib/systemd/systemd-journald from read, write access on the file /memfd:sd-systemd-coredum (deleted).
SELinux is preventing /usr/lib/systemd/systemd-journald from read, write acce...
Status: CLOSED DUPLICATE of bug 1253319
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:28287d2f3a8949a7d4f025557a5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 17:07 EST by Wilf
Modified: 2016-01-11 08:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 08:09:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wilf 2015-11-26 17:07:53 EST
Description of problem:
? Playing a game under steam (during which gnome-shell had to be reastarted cos it was using 100% CPU)
SELinux is preventing /usr/lib/systemd/systemd-journald from read, write access on the file /memfd:sd-systemd-coredum (deleted).

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/memfd:sd-systemd-coredum (deleted) default label should be etc_runtime_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /memfd:sd-systemd-coredum (deleted)

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that systemd-journald should be allowed read write access on the memfd:sd-systemd-coredum (deleted) file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-journal /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:syslogd_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /memfd:sd-systemd-coredum (deleted) [ file ]
Source                        systemd-journal
Source Path                   /usr/lib/systemd/systemd-journald
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-219-25.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.18.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.6-200.fc22.x86_64 #1 SMP Tue
                              Nov 10 16:45:19 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-26 21:26:49 GMT
Last Seen                     2015-11-26 21:26:49 GMT
Local ID                      8af53943-9026-47d2-b612-2270162a7f8f

Raw Audit Messages
type=AVC msg=audit(1448573209.903:948): avc:  denied  { read write } for  pid=426 comm="systemd-journal" path=2F6D656D66643A73642D73797374656D642D636F726564756D202864656C6574656429 dev="tmpfs" ino=207087 scontext=system_u:system_r:syslogd_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1448573209.903:948): arch=x86_64 syscall=recvmsg success=yes exit=0 a0=4 a1=7fff06698960 a2=40000040 a3=0 items=0 ppid=1 pid=426 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-journal exe=/usr/lib/systemd/systemd-journald subj=system_u:system_r:syslogd_t:s0 key=(null)

Hash: systemd-journal,syslogd_t,tmpfs_t,file,read,write

Version-Release number of selected component:
selinux-policy-3.13.1-128.18.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.6-200.fc22.x86_64
type:           libreport
Comment 1 Wilf 2015-11-26 17:11:54 EST
Found this, may be relevant
https://bugzilla.redhat.com/show_bug.cgi?id=1253319
Comment 2 Lukas Vrabec 2016-01-11 08:09:52 EST

*** This bug has been marked as a duplicate of bug 1253319 ***

Note You need to log in before you can comment on or make changes to this bug.