This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1285901 - nunc-stans creates additional thread pool
nunc-stans creates additional thread pool
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-26 18:00 EST by Viktor Ashirov
Modified: 2015-12-22 16:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 16:34:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viktor Ashirov 2015-11-26 18:00:40 EST
Description of problem:
Build 389-ds-base-1.3.4.0-21.el7_2.x86_64:
# tail -n1 /etc/profile
export MAX_THREADS=100

nsslapd-threadnumber: 30
nsslapd-enable-nunc-stans: off

# ps huH p $(pidof ns-slapd) | wc -l
41

nsslapd-enable-nunc-stans: on
# ps huH p $(pidof ns-slapd) | wc -l
72

# ldapsearch -h localhost -D "cn=Directory Manager" -w Secret123 -b "cn=monitor" -s base  threads  -LLL
dn: cn=monitor
threads: 30

On the older version (389-ds-base-1.3.4.0-19.el7.x86_64):

nsslapd-enable-nunc-stans: off
# ps huH p $(pidof ns-slapd) | wc -l
41

nsslapd-enable-nunc-stans: on
# ps huH p $(pidof ns-slapd) | wc -l
142

# ldapsearch -h localhost -D "cn=Directory Manager" -w Secret123 -b "cn=monitor" -s base  threads  -LLL
dn: cn=monitor
threads: 30

Looks like nunc-stans created additional thread pool (30 + 100 + 12 service threads). And on a new version it's 30 + 30 + 12.
Comment 1 mreynolds 2015-12-22 16:34:28 EST
Nunc-stans creates its own event catching thread pool, and it uses the DS thread number config setting.  So you should see double the number of threads.

Closing this out as not a bug, feel free to reopen it if I missed something.

Note You need to log in before you can comment on or make changes to this bug.