Bug 1285903 - newly-added livenet-generator.sh script is not executable, entirely breaks installer images ("Permission denied")
newly-added livenet-generator.sh script is not executable, entirely breaks in...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: dracut-maint-list
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F24AlphaBlocker
  Show dependency treegraph
 
Reported: 2015-11-26 18:16 EST by Adam Williamson
Modified: 2015-11-27 04:13 EST (History)
5 users (show)

See Also:
Fixed In Version: dracut-044-4.git20151127.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 04:13:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against upstream dracut git master to fix the bug (639 bytes, patch)
2015-11-26 18:16 EST, Adam Williamson
no flags Details | Diff

  None (edit)
Description Adam Williamson 2015-11-26 18:16:23 EST
2015-11-26 Rawhide nightly boot.iso's completely fail to boot. With a bit of research we easily see the cause:

Failed to execute /usr/lib/systemd/system-generators/dracut-livenet-generator: Permission denied
/usr/lib/systemd/system-generators/dracut-livenet-generator failed with error code 1.

this script was added recently:

https://git.kernel.org/cgit/boot/dracut/dracut.git/commit/?id=a455ad1c272170664022b4cc0a160fe9c737d993

but was set to the wrong mode (0644 not 0755). This is an automatic blocker for F24 Alpha:

"Complete failure of any release-blocking TC/RC image to boot at all under any circumstance - "DOA" image (conditional failure is not an automatic blocker)"

https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers

Attaching a patch.
Comment 1 Adam Williamson 2015-11-26 18:16 EST
Created attachment 1099486 [details]
patch against upstream dracut git master to fix the bug

Note You need to log in before you can comment on or make changes to this bug.