Bug 1285961 - glusterfsd to support volfile-server-transport type "unix"
glusterfsd to support volfile-server-transport type "unix"
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed Ashiq
:
Depends On: 1279484 1286604
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 00:10 EST by Mohamed Ashiq
Modified: 2016-04-19 03:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279484
Environment:
Last Closed: 2016-04-19 03:49:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-11-27 00:10:32 EST
+++ This bug was initially created as a clone of Bug #1279484 +++

Description of problem:
glusterfsd does not support unix domain socket. In case if glusterd is binded to a specific-IP, glusterfsd clients(like quota auxiliary mount) fails. Using unix domain socket glusterfsd will over come the failure.


Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1.create and start a volume
2.glusterfs -s <unix socket path> --volfile-server-transport unix --volfile-id <volume-name> <mount-point>

Actual results:
Fails to communicate using unix domain socket

Expected results:
It should be able to communicate using unix domain socket

Additional info:

--- Additional comment from Mohamed Ashiq on 2015-11-09 10:38:25 EST ---

Patch:

http://review.gluster.org/12556

--- Additional comment from Vijay Bellur on 2015-11-19 07:29:03 EST ---

REVIEW: http://review.gluster.org/12556 (glusterfsd: To support volfile-server-transport type "unix") posted (#4) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-19 22:59:40 EST ---

COMMIT: http://review.gluster.org/12556 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 7fbc38531acbc39369d3b91ba126fc4147ab89d1
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Mon Nov 9 20:43:17 2015 +0530

    glusterfsd: To support volfile-server-transport type "unix"
    
    glusterfsd fails if the glusterd is bind to specific-IP address.
    This patch helps glusterfsd to get the volfile using Unix domain socket.
    glusterfs -s <unix socket path> --volfile-server-transport unix
              --volfile-id <volume-name> <mount-point>
    The patch checks if the volfile-server-transport is of type "unix",
    If It is then uses rpc_transport_unix_options_build to get the volfile.
    
    Change-Id: I81b881e7ac5a3a4f2ac83c789c385cf547f0d53e
    BUG: 1279484
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/12556
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

--- Additional comment from Vijay Bellur on 2015-11-26 02:10:28 EST ---

REVIEW: http://review.gluster.org/12757 (glusterd: glusterfsd to support volfile-server-transport type "unix") posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-26 03:10:22 EST ---

REVIEW: http://review.gluster.org/12757 (glusterd: glusterfsd to support volfile-server-transport type "unix") posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-26 22:41:25 EST ---

COMMIT: http://review.gluster.org/12757 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 0db6d57a184ed79eb3142c42957b1a2415744011
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Thu Nov 26 12:32:10 2015 +0530

    glusterd: glusterfsd to support volfile-server-transport type "unix"
    
    If glusterfsd uses transport type "unix", 'addrstr' can be empty. So,
    it may fail to fetch the trusted volfile in this case. This patch allows
    to fetch volfile even if addrstr is empty.
    
    Change-Id: I831c5cd0b07b90ae843ec63f0fad9241d9407f6b
    BUG: 1279484
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Reviewed-on: http://review.gluster.org/12757
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 1 Vijay Bellur 2015-11-27 00:27:35 EST
REVIEW: http://review.gluster.org/12769 (glusterfsd: To support volfile-server-transport type "unix") posted (#1) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 2 Vijay Bellur 2015-11-30 01:30:31 EST
REVIEW: http://review.gluster.org/12769 (glusterfsd: To support volfile-server-transport type "unix") posted (#2) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Vijay Bellur 2015-11-30 01:30:35 EST
REVIEW: http://review.gluster.org/12815 (glusterd: glusterfsd to support volfile-server-transport type "unix") posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 4 Vijay Bellur 2015-12-03 06:40:01 EST
COMMIT: http://review.gluster.org/12769 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 113e2ac257cf75efd12fcfd47b7eed7ad08ee000
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Mon Nov 9 20:43:17 2015 +0530

    glusterfsd: To support volfile-server-transport type "unix"
    
    glusterfsd fails if the glusterd is bind to specific-IP address.
    This patch helps glusterfsd to get the volfile using Unix domain socket.
    glusterfs -s <unix socket path> --volfile-server-transport unix
              --volfile-id <volume-name> <mount-point>
    The patch checks if the volfile-server-transport is of type "unix",
    If It is then uses rpc_transport_unix_options_build to get the volfile.
    
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    
    >Change-Id: I81b881e7ac5a3a4f2ac83c789c385cf547f0d53e
    >BUG: 1279484
    >Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    >Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    >Reviewed-on: http://review.gluster.org/12556
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: Ic3eeacc78aca3df3c07e5a9228043f3d7cdf094c
    BUG: 1285961
    Reviewed-on: http://review.gluster.org/12769
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 5 Vijay Bellur 2015-12-04 06:17:41 EST
COMMIT: http://review.gluster.org/12815 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 543380147e7b035ac034672cf69a391e4d76e5ff
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Thu Nov 26 12:32:10 2015 +0530

    glusterd: glusterfsd to support volfile-server-transport type "unix"
    
    If glusterfsd uses transport type "unix", 'addrstr' can be empty. So,
    it may fail to fetch the trusted volfile in this case. This patch allows
    to fetch volfile even if addrstr is empty.
    
            Backport of http://review.gluster.org/#/c/12757/
    
    > Change-Id: I831c5cd0b07b90ae843ec63f0fad9241d9407f6b
    > BUG: 1279484
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    > Reviewed-on: http://review.gluster.org/12757
    > Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I831c5cd0b07b90ae843ec63f0fad9241d9407f6b
    BUG: 1285961
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Reviewed-on: http://review.gluster.org/12815
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 6 Kaushal 2016-04-19 03:49:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.