Bug 1285997 - incorrect file extension, png instead of jpg, for mountain-crossing.png
incorrect file extension, png instead of jpg, for mountain-crossing.png
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: f22-backgrounds (Show other bugs)
22
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
: 1322950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 02:54 EST by Trevor Cordes
Modified: 2016-05-07 08:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: f22-backgrounds-22.1.1-1.fc23 f22-backgrounds-22.1.1-1.fc22 f22-backgrounds-22.1.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 15:20:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevor Cordes 2015-11-27 02:54:20 EST
Description of problem:
/usr/share/backgrounds/f22/extras/mountain-crossing.png
in
f22-backgrounds-extras-base-22.1.0-1.fc22.noarch

has incorrect file extension:

file /usr/share/backgrounds/f22/extras/mountain-crossing.png
/usr/share/backgrounds/f22/extras/mountain-crossing.png: JPEG image data, Exif standard: [TIFF image data, big-endian, direntries=16, height=4000, bps=0, PhotometricIntepretation=RGB, manufacturer=NIKON CORPORATION, model=NIKON D3200, orientation=upper-left, width=6016], baseline, precision 8, 6016x3448, frames 3


Version-Release number of selected component (if applicable):
f22-backgrounds-extras-base-22.1.0-1.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf install f22-backgrounds-extras-base
2. file /usr/share/backgrounds/f22/extras/mountain-crossing.png
3.

Actual results:
JPEG image data...


Expected results:
PNG image data...

Additional info:
The other png files in the same directory are png files, and hence are OK (not buggy).
Comment 1 Luya Tshimbalanga 2016-04-16 01:50:06 EDT
*** Bug 1322950 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2016-04-18 08:42:29 EDT
f22-backgrounds-22.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-daa8b375a8
Comment 3 Fedora Update System 2016-04-18 08:42:40 EDT
f22-backgrounds-22.1.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e9010e5366
Comment 4 Fedora Update System 2016-04-18 08:42:47 EDT
f22-backgrounds-22.1.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-863809e207
Comment 5 Fedora Update System 2016-04-18 14:50:58 EDT
f22-backgrounds-22.1.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e9010e5366
Comment 6 Fedora Update System 2016-04-18 22:20:14 EDT
f22-backgrounds-22.1.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-863809e207
Comment 7 Fedora Update System 2016-04-18 22:23:20 EDT
f22-backgrounds-22.1.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-daa8b375a8
Comment 8 Mike Simms 2016-04-19 19:29:14 EDT
the bad file is in the f22-backgrounds-extras package. how exactly are the above updates a fix for this issue? am I missing something blindingly obvious here? I looked at the update contents over on bodhi and can't see any reference to it.
Comment 9 Luya Tshimbalanga 2016-04-19 19:58:33 EDT
Mountain-crossing should be jpeg rather than png.
Comment 10 Trevor Cordes 2016-04-20 00:26:47 EDT
Yes, Mike is correct, the f22-backgrounds rpm does not have the file in question.  It is for sure in f22-backgrounds-extras-base as originally reported.
Comment 11 Luya Tshimbalanga 2016-04-20 13:22:01 EDT
I see now. f22-backgrounds-extras-base is a subpackage of f22-backgrounds, bugzilla database does not have a separate element for that purpose. I put a short notice of bodhi.
Comment 12 Fedora Update System 2016-04-20 15:20:15 EDT
f22-backgrounds-22.1.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-04-27 18:20:33 EDT
f22-backgrounds-22.1.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-05-07 08:06:22 EDT
f22-backgrounds-22.1.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.