Bug 1286007 - SELinux prevents dspam web UI from working
SELinux prevents dspam web UI from working
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 03:44 EST by Milos Malik
Modified: 2016-05-10 16:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-282.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:02:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2015-11-27 03:44:55 EST
Description of problem:

Version-Release number of selected component (if applicable):
dspam-3.10.2-7.el6.x86_64
dspam-libs-3.10.2-7.el6.x86_64
dspam-web-3.10.2-7.el6.x86_64
httpd-2.2.15-45.el6.x86_64
httpd-tools-2.2.15-45.el6.x86_64
selinux-policy-3.7.19-279.el6.noarch
selinux-policy-targeted-3.7.19-279.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. get a RHEL-6.7 machine (active targeted policy)
2. install httpd, change its configuration so that it listens on port 8009 too
3. install dspam and dspam-web packages
4. htpasswd -c /var/www/dspam-passwd test-user
5. start the httpd service
6. links http://localhost:8009/ and log in as test-user

Actual results (enforcing mode):
----
type=OBJ_PID msg=audit(11/27/2015 03:31:58.546:258) : opid=4272 oauid=root ouid=apache oses=4 obj=unconfined_u:system_r:httpd_suexec_t:s0 ocomm=suexec 
type=SYSCALL msg=audit(11/27/2015 03:31:58.546:258) : arch=x86_64 syscall=kill success=no exit=-13(Permission denied) a0=0x10b0 a1=SIGTERM a2=0x3 a3=0x7ffceac37320 items=0 ppid=3599 pid=3607 auid=root uid=apache gid=apache euid=apache suid=apache fsuid=apache egid=apache sgid=apache fsgid=apache tty=(none) ses=4 comm=httpd exe=/usr/sbin/httpd subj=unconfined_u:system_r:httpd_t:s0 key=(null) 
type=AVC msg=audit(11/27/2015 03:31:58.546:258) : avc:  denied  { signal } for  pid=3607 comm=httpd scontext=unconfined_u:system_r:httpd_t:s0 tcontext=unconfined_u:system_r:httpd_suexec_t:s0 tclass=process 
----
type=OBJ_PID msg=audit(11/27/2015 03:31:58.546:259) : opid=4272 oauid=root ouid=apache oses=4 obj=unconfined_u:system_r:httpd_suexec_t:s0 ocomm=suexec 
type=SYSCALL msg=audit(11/27/2015 03:31:58.546:259) : arch=x86_64 syscall=kill success=no exit=-13(Permission denied) a0=0x10b0 a1=SIGKILL a2=0xffffffff a3=0x7ffceac37320 items=0 ppid=3599 pid=3607 auid=root uid=apache gid=apache euid=apache suid=apache fsuid=apache egid=apache sgid=apache fsgid=apache tty=(none) ses=4 comm=httpd exe=/usr/sbin/httpd subj=unconfined_u:system_r:httpd_t:s0 key=(null) 
type=AVC msg=audit(11/27/2015 03:31:58.546:259) : avc:  denied  { sigkill } for  pid=3607 comm=httpd scontext=unconfined_u:system_r:httpd_t:s0 tcontext=unconfined_u:system_r:httpd_suexec_t:s0 tclass=process 
----

Actual results (permissive mode):
----
type=OBJ_PID msg=audit(11/27/2015 03:40:47.903:267) : opid=4469 oauid=root ouid=apache oses=4 obj=unconfined_u:system_r:httpd_suexec_t:s0 ocomm=suexec 
type=SYSCALL msg=audit(11/27/2015 03:40:47.903:267) : arch=x86_64 syscall=kill success=yes exit=0 a0=0x1175 a1=SIGTERM a2=0x3 a3=0x7ffceac37320 items=0 ppid=3599 pid=3608 auid=root uid=apache gid=apache euid=apache suid=apache fsuid=apache egid=apache sgid=apache fsgid=apache tty=(none) ses=4 comm=httpd exe=/usr/sbin/httpd subj=unconfined_u:system_r:httpd_t:s0 key=(null) 
type=AVC msg=audit(11/27/2015 03:40:47.903:267) : avc:  denied  { signal } for  pid=3608 comm=httpd scontext=unconfined_u:system_r:httpd_t:s0 tcontext=unconfined_u:system_r:httpd_suexec_t:s0 tclass=process 
----

Expected results:
 * no SELinux denials
Comment 1 Miroslav Grepl 2015-11-30 06:59:55 EST
We have fixes in RHEL-7.

#!!!! This avc is allowed in the current policy
allow httpd_t httpd_suexec_t:process signal;
Comment 5 errata-xmlrpc 2016-05-10 16:02:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0763.html

Note You need to log in before you can comment on or make changes to this bug.