Bug 1286009 - make distcheck fails due to permission denied for target 'vdsm-api.html
make distcheck fails due to permission denied for target 'vdsm-api.html
Status: CLOSED WONTFIX
Product: vdsm
Classification: oVirt
Component: Build (Show other bugs)
---
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Yaniv Bronhaim
Pavel Stehlik
: BuildBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 03:54 EST by Sandro Bonazzola
Modified: 2016-11-29 05:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-29 05:23:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ybronhei: ovirt‑4.2?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2015-11-27 03:54:20 EST
Description of problem:
make distcheck fails with:

make[3]: Entering directory '/NotBackedUp/sbonazzo/upstream/vdsm/vdsm-4.17.999/_build/sub/lib/api'
  Generate vdsm-api.html
PYTHONDONTWRITEBYTECODE=1 PYTHONPATH=../../../../lib/api/../lib \
    /usr/bin/python ../../../../lib/api/process-schema.py \
              ../../../../lib/api/vdsmapi-schema.json ../../../../lib/api/vdsm-api.html
Traceback (most recent call last):
  File "../../../../lib/api/process-schema.py", line 372, in <module>
    main()
  File "../../../../lib/api/process-schema.py", line 368, in main
    create_doc(symbols, output)
  File "../../../../lib/api/process-schema.py", line 292, in create_doc
    with open(filename, 'w') as f:
IOError: [Errno 13] Permission denied: '../../../../lib/api/vdsm-api.html'
Makefile:646: recipe for target 'vdsm-api.html' failed
make[3]: *** [vdsm-api.html] Error 1
make[3]: Leaving directory '/NotBackedUp/sbonazzo/upstream/vdsm/vdsm-4.17.999/_build/sub/lib/api'
Makefile:463: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/NotBackedUp/sbonazzo/upstream/vdsm/vdsm-4.17.999/_build/sub/lib'
Makefile:549: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/NotBackedUp/sbonazzo/upstream/vdsm/vdsm-4.17.999/_build/sub'
Makefile:758: recipe for target 'distcheck' failed
make: *** [distcheck] Error 1
Comment 1 Yaniv Kaul 2016-03-13 11:16:51 EDT
Is this going to be handled in 4.0?
Comment 2 Yaniv Bronhaim 2016-04-18 07:16:40 EDT
part of the work is on progress (https://gerrit.ovirt.org/#/c/52508/) but still delayed. hopefully we'll get to fix it to 4.0. The urgency is not high and this doesn't block anything. its a bit complex due to vdsm template files
Comment 3 Sandro Bonazzola 2016-05-02 06:02:17 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 Yaniv Bronhaim 2016-11-29 05:22:52 EST
I rechecked that again. We can fix specific parts but the main issue is our way of generating the in files during make. In distcheck the generated files are not generated in the dist folder

I do not see us investing more time in this use case. please re-open if relevant

Note You need to log in before you can comment on or make changes to this bug.