Bug 1286017 - We need to skip data self-heal for arbiter bricks
We need to skip data self-heal for arbiter bricks
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On:
Blocks: 1286169
  Show dependency treegraph
 
Reported: 2015-11-27 04:04 EST by Ravishankar N
Modified: 2016-06-16 09:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1286169 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-11-27 04:04:26 EST
Description of problem:

The arbiter brick anyway stores zero-byte files. There's no point of sending writes to the arbiter brick, only for it to unwind the writes without performing any action.
Comment 1 Vijay Bellur 2015-11-27 04:05:48 EST
REVIEW: http://review.gluster.org/12777 (afr: skip healing data blocks for arbiter) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2015-12-10 08:04:18 EST
REVIEW: http://review.gluster.org/12777 (afr: skip healing data blocks for arbiter) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2016-01-11 08:04:45 EST
REVIEW: http://review.gluster.org/12777 (afr: skip healing data blocks for arbiter) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Vijay Bellur 2016-01-11 08:08:14 EST
REVIEW: http://review.gluster.org/12777 (afr: skip healing data blocks for arbiter) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 5 Vijay Bellur 2016-01-11 10:49:04 EST
REVIEW: http://review.gluster.org/12777 (afr: skip healing data blocks for arbiter) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 6 Vijay Bellur 2016-01-12 05:44:51 EST
REVIEW: http://review.gluster.org/12777 (afr: skip healing data blocks for arbiter) posted (#6) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 7 Vijay Bellur 2016-01-18 05:43:08 EST
REVIEW: http://review.gluster.org/12777 (afr: skip healing data blocks for arbiter) posted (#7) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 8 Vijay Bellur 2016-01-18 08:44:53 EST
COMMIT: http://review.gluster.org/12777 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b95ad51e00d6076d37809bcc50b89fee1cf248ef
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Jan 11 12:58:16 2016 +0000

    afr: skip healing data blocks for arbiter
    
    1 ....but still do other parts of data-self-heal like restoring the time
    and undo pending xattrs.
    
    2. Perform undo_pending inside inodelks.
    
    3. If arbiter is the only sink, do these other parts of data-self-heal
    inside a single lock-unlock sequence.
    
    Change-Id: I64c9d5b594375f852bfb73dee02c66a9a67a7176
    BUG: 1286017
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12777
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 9 Niels de Vos 2016-06-16 09:47:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.