Bug 1286020 - dspam tries to read /etc/passwd
dspam tries to read /etc/passwd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Simon Sekidde
Milos Malik
:
Depends On:
Blocks: 1288133
  Show dependency treegraph
 
Reported: 2015-11-27 04:08 EST by Milos Malik
Modified: 2016-11-03 22:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-83.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288133 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:25:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2015-11-27 04:08:06 EST
Description of problem:
 * AFAICT the dspam web UI works fine, but the AVCs are generated

Version-Release number of selected component (if applicable):
dspam-3.10.2-11.el7.x86_64
dspam-libs-3.10.2-11.el7.x86_64
dspam-web-3.10.2-11.el7.x86_64
httpd-2.4.6-40.el7.x86_64
httpd-manual-2.4.6-40.el7.noarch
httpd-tools-2.4.6-40.el7.x86_64
selinux-policy-3.13.1-60.el7.noarch
selinux-policy-targeted-3.13.1-60.el7.noarch

How reproducible:
 * always

Steps to Reproduce:
1. get a RHEL-7.2 machine (active targeted policy)
2. install httpd, change its configuration so that it listens on port 8009 too
3. install dspam and dspam-web packages
4. htpasswd -c /var/www/dspam-passwd test-user
5. start the httpd service
6. links http://localhost:8009/ and log in as test-user

Actual results:
----
type=PATH msg=audit(11/27/2015 03:49:54.491:567) : item=0 name=/etc/passwd inode=29739 dev=fd:01 mode=file,644 ouid=root ogid=root rdev=00:00 obj=system_u:object_r:passwd_file_t:s0 objtype=NORMAL 
type=CWD msg=audit(11/27/2015 03:49:54.491:567) :  cwd=/var/www/dspam 
type=SYSCALL msg=audit(11/27/2015 03:49:54.491:567) : arch=x86_64 syscall=open success=no exit=-13(Permission denied) a0=0x7f9a90ab2092 a1=O_RDONLY|O_CLOEXEC a2=0x1b6 a3=0x24 items=1 ppid=7817 pid=7818 auid=unset uid=dspam gid=dspam euid=dspam suid=dspam fsuid=dspam egid=mail sgid=mail fsgid=mail tty=(none) ses=unset comm=dspam exe=/usr/bin/dspam subj=system_u:system_r:dspam_script_t:s0 key=(null) 
type=AVC msg=audit(11/27/2015 03:49:54.491:567) : avc:  denied  { read } for  pid=7818 comm=dspam name=passwd dev="dm-1" ino=29739 scontext=system_u:system_r:dspam_script_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file 
----

Expected results:
 * no SELinux denials, dontaudit candidate ?
Comment 5 errata-xmlrpc 2016-11-03 22:25:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.