This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286026 - partial_activation check fails in pacemaker
partial_activation check fails in pacemaker
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Oyvind Albrigtsen
cluster-qe@redhat.com
:
Depends On:
Blocks: 1269194
  Show dependency treegraph
 
Reported: 2015-11-27 04:38 EST by Josef Zimek
Modified: 2016-08-02 13:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-02 13:36:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Zimek 2015-11-27 04:38:59 EST
Description of problem:
=======================
Customer is using a HA-LVM mirror logical volumes as resource for Pacemaker cluster.

When using the option 'partial_activation=true', like in the following resource,

# pcs resource show vgexample
 Resource: vgexample (class=ocf provider=heartbeat type=LVM)
  Attributes: volgrpname=vg_example exclusive=true partial_activation=true
 ...

Customer expects that in case of failure of a logical volume segment (missing PV), the cluster can still activate the VG and start the volume (in the LVM script, 'partial_activation=true' converts to 'vgchange -ay ... <vg> --partial')


But when running:

# pcs resource move res_grp    # res_grp is resource group with the vgexample resource

it fails.


It's because in the LVM ocf script, before doing the vgchange, the script
runs 'vgck <vg>' (in the LVM_validate_all() function) which fails because of
the missing PV.

When commenting out the vgck part as a test and everything worked as expected.





Version-Release number of selected component (if applicable):
=============================================================
RHEL 6.7

# rpm -qf /usr/lib/ocf/resource.d/heartbeat/LVM
resource-agents-3.9.5-24.el6.x86_64



How reproducible:
=================
always


Steps to Reproduce:
===================
1. move resource group which consist of LVM resource with partial_activation=true


Actual results:
===============
Resource group fails to move


Expected results:
=================
The LVM_validate_all() should check the value of OCF_RESKEY_partial_activation
before trying vgck. And the resource group moves to other node


Additional info:
Comment 2 Oyvind Albrigtsen 2015-11-27 04:54:33 EST
Can he test the patch I've attached to the following bz?
https://bugzilla.redhat.com/show_bug.cgi?id=1266173
Comment 3 Oyvind Albrigtsen 2015-12-16 09:38:33 EST
Josef: Can you ask the customer if he can test the patch mentioned in comment #2?
Comment 4 Josef Zimek 2015-12-16 10:03:46 EST
Oyvind: Yes, I will let you know the result once I got feedback from customer. Thanks
Comment 7 John Ruemker 2016-08-02 13:36:26 EDT
Closing this out.  The issue described is resolved via the errata that was released in 6.8 via Bugzilla #1266173.  The customer case eventually closed without confirmation of the fix, but we expect that it should have been resolved.

Note You need to log in before you can comment on or make changes to this bug.