Bug 1286033 - Checkbox "Preallocate disk" doesn't get saved for a Compute Profile
Checkbox "Preallocate disk" doesn't get saved for a Compute Profile
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources (Show other bugs)
6.1.4
All All
medium Severity high (vote)
: Beta
: --
Assigned To: Marek Hulan
Kedar Bidarkar
http://projects.theforeman.org/issues...
: PrioBumpPM, Triaged
Depends On:
Blocks: 1317530 1320313
  Show dependency treegraph
 
Reported: 2015-11-27 05:01 EST by Martin Tessun
Modified: 2017-10-17 05:24 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1320313 (view as bug list)
Environment:
Last Closed: 2016-07-27 05:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2070203 None None None Never

  None (edit)
Description Martin Tessun 2015-11-27 05:01:03 EST
Description of problem:
in Web UI go to Infrastructure -> "Compute Profile" -> Select a RHEV Compute resource.  In the section "Volumes" check the box for "Preallocate Disk" and click "Submit".  If you re-edit this profile, checkbox is unchecked again.

Version-Release number of selected component (if applicable):
Satellite 6.1.4

How reproducible:
always

Steps to Reproduce:
1. Go to Infrastructure -> Compute Resources
2. Add a RHEV-M Compute resource
3. Go to Infrastructure -> Compute Profile
4. Select a Profile
5. Select the RHEV-M Compute resource
6. Add a Volume and Check "Preallocate Disk"
7. Save the profile
8. Edit the profile again

Actual results:
The Checkbox "Preallocate Disk" is again unchecked

Expected results:
The checkbox should remain checked.

Additional info:
There is a similiar foreman-bug upstream:
http://projects.theforeman.org/issues/9932
Comment 2 Bryan Kearney 2015-12-01 13:08:56 EST
Created redmine issue http://projects.theforeman.org/issues/12648 from this bug
Comment 4 Bryan Kearney 2015-12-02 15:04:23 EST
Connecting redmine issue http://projects.theforeman.org/issues/9932 from this bug
Comment 5 Bryan Kearney 2015-12-02 16:01:59 EST
Upstream bug component is Compute Resources
Comment 8 Bryan Kearney 2016-03-10 06:12:17 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/9932 has been closed
-------------
Marek Hulán
Applied in changeset commit:545716c40c34acca04113642fd934af5ae1e8032.
Comment 9 Kedar Bidarkar 2016-03-28 15:34:26 EDT
VERIFIED with sat62-snap4-compose1

The checkbox for "Preallocate disk" remains selected even after save and edit.
Comment 12 errata-xmlrpc 2016-07-27 05:20:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.