Bug 1286058 - Brick crashes because of race in bit-rot init
Brick crashes because of race in bit-rot init
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: bitrot (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
RamaKasturi
: ZStream
Depends On: 1285616
Blocks: 1260783 1285758
  Show dependency treegraph
 
Reported: 2015-11-27 05:25 EST by RamaKasturi
Modified: 2016-09-17 10:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285616
Environment:
Last Closed: 2016-03-01 01:03:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2015-11-27 05:25:57 EST
+++ This bug was initially created as a clone of Bug #1285616 +++

Description of problem:
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fce642eb420 in pthread_mutex_lock () from ./lib64/libpthread.so.0
(gdb) bt
#0  0x00007fce642eb420 in pthread_mutex_lock () from ./lib64/libpthread.so.0
#1  0x00007fce52ee2e13 in br_stub_worker (data=0x7fce54010f90)
    at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/xlators/features/bit-rot/src/stub/bit-rot-stub-helpers.c:337
#2  0x00007fce642e9a51 in start_thread () from ./lib64/libpthread.so.0
#3  0x00007fce63c5393d in clone () from ./lib64/libc.so.6
(gdb) fr 1
#1  0x00007fce52ee2e13 in br_stub_worker (data=0x7fce54010f90)
    at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/xlators/features/bit-rot/src/stub/bit-rot-stub-helpers.c:337
337	/home/jenkins/root/workspace/rackspace-regression-2GB-triggered/xlators/features/bit-rot/src/stub/bit-rot-stub-helpers.c: No such file or directory.
(gdb) info locals
priv = 0x0
this = 0x7fce54010f90
stub = 0x0
ret = 0

init may not have initialized this->private by the time br_stub_worker starts running, leading to NULL dereference.
Version-Release number of selected component (if applicable):

How reproducible:
This is observed at https://build.gluster.org/job/rackspace-regression-2GB-triggered/16180/consoleFull

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-11-25 23:36:24 EST ---

REVIEW: http://review.gluster.org/12754 (features/bit-rot: Fix NULL dereference) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-26 04:03:33 EST ---

REVIEW: http://review.gluster.org/12754 (features/bit-rot: Fix NULL dereference) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-26 23:04:23 EST ---

COMMIT: http://review.gluster.org/12754 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit a1919e91279a6c691fbd3dd6c0d97e74e78ccf22
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Nov 26 09:58:39 2015 +0530

    features/bit-rot: Fix NULL dereference
    
    Problem:
    By the time br_stub_worker is accessing this->private in it's
    thread, 'init' may not have set 'this->private = priv'. This
    leads to NULL dereference leading to brick crash.
    
    Fix:
    Set this->private before launching these threads.
    
    Change-Id: Ic797eb195fdd0c70d19f28d0b97bc0181fd3dd2f
    BUG: 1285616
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/12754
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 4 RamaKasturi 2015-12-08 02:14:54 EST
verified and works fine with build glusterfs-3.7.5-9.el7rhgs.x86_64. Did not see any brick crash when volume stops and starts.
Comment 7 errata-xmlrpc 2016-03-01 01:03:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.