Bug 1286066 - Katello-agent installation fails due to dependency issue
Katello-agent installation fails due to dependency issue
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.4
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Tazim Kolhar
:
Depends On:
Blocks: 1269509
  Show dependency treegraph
 
Reported: 2015-11-27 05:29 EST by Tazim Kolhar
Modified: 2016-04-25 20:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 02:20:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2015-11-27 05:29:55 EST
Description of problem:
Katello-agent installation fails due to dependency issue

Version-Release number of selected component (if applicable):
# rpm -qa | grep foreman
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.10-1.el7sat.noarch
foreman-gce-1.7.2.47-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-debug-1.7.2.47-1.el7sat.noarch
foreman-compute-1.7.2.47-1.el7sat.noarch
foreman-vmware-1.7.2.47-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.4-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-ovirt-1.7.2.47-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.22-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
foreman-selinux-1.7.2.17-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
foreman-postgresql-1.7.2.47-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.24-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-libvirt-1.7.2.47-1.el7sat.noarch
foreman-1.7.2.47-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.7-1.el7sat.noarch
foreman-proxy-1.7.2.6-1.el7sat.noarch



How reproducible:
everytime

Steps to Reproduce:
1.yum install -y katello-agent
2.
3.

Actual results:
Error: Package: python-qpid-proton-0.9-10.el7.x86_64 (Default_Organization_sat_tools_sat_tools_repo)
           Requires: libpython2.7.so.1.0()(64bit)
Error: Package: python-pulp-agent-lib-2.6.0.17-1.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: python-pulp-rpm-common-2.6.0.17-1.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: python-gofer-proton-2.6.7-2.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: python-pulp-common-2.6.0.17-1.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: python-qpid-proton-0.9-10.el7.x86_64 (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: gofer-2.6.7-2.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: systemd
Error: Package: python-gofer-2.6.7-2.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: python-isodate-0.5.0-4.pulp.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: pulp-rpm-handlers-2.6.0.17-1.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: python-qpid-proton-0.9-10.el7.x86_64 (Default_Organization_sat_tools_sat_tools_repo)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gofer-2.6.7-2.el7sat.noarch (Default_Organization_sat_tools_sat_tools_repo)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201409260744.x86_64/6.6)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-20.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-36.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-37.el6_4.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
           Available: python-2.6.6-64.el6.x86_64 (rhel-6-server-rpms)
               python(abi) = 2.6
Error: Package: qpid-proton-c-0.9-10.el7.x86_64 (Default_Organization_sat_tools_sat_tools_repo)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
katello-agent installation successful

Additional info:
Comment 1 Stuart Auchterlonie 2015-11-27 05:50:36 EST
You appear to be installing the RHEL7 Satellite rpms onto a RHEL6 system.
Does it work properly when you install the RHEL6 satellite rpms?
Comment 2 Tazim Kolhar 2015-11-30 02:20:16 EST
Hi,

   yes, by mistake I tried installing rhel7 rpms on rhel6 system

   I corrected the change and so now able to install it

Installed:
  katello-agent.noarch 0:2.2.6-1.el6                                            

Dependency Installed:
  gofer.noarch 0:2.6.7-2.el6                                                    
  pulp-rpm-handlers.noarch 0:2.6.0.17-1.el6                                     
  python-gofer.noarch 0:2.6.7-2.el6                                             
  python-gofer-proton.noarch 0:2.6.7-2.el6                                      
  python-isodate.noarch 0:0.5.0-4.pulp.el6_6sat                                 
  python-pulp-agent-lib.noarch 0:2.6.0.17-1.el6                                 
  python-pulp-common.noarch 0:2.6.0.17-1.el6                                    
  python-pulp-rpm-common.noarch 0:2.6.0.17-1.el6                                
  python-qpid-proton.x86_64 0:0.9-10.el6                                        
  qpid-proton-c.x86_64 0:0.9-10.el6                                             

Complete!

Closing this as not a BZ

Note You need to log in before you can comment on or make changes to this bug.