Bug 1286067 - DHT + add brick : Directory self heal is fixing hash layout for few Directories
DHT + add brick : Directory self heal is fixing hash layout for few Directories
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Nithya Balachandran
storage-qa-internal@redhat.com
dht-add-brick,
: ZStream
Depends On: 1049771
Blocks: 1056406
  Show dependency treegraph
 
Reported: 2015-11-27 05:30 EST by Susant Kumar Palai
Modified: 2016-09-06 04:39 EDT (History)
12 users (show)

See Also:
Fixed In Version: 3.7.9-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1049771
Environment:
Last Closed: 2016-09-06 04:39:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Raghavendra G 2016-07-01 07:53:43 EDT
This is not an issue affected by turning lookup-optimize=on. This is for the reason that its an add-brick scenario, during which clients resort to lookup-everywhere even though lookup-optimize=on. Hence dropping the tag.
Comment 3 Prasad Desala 2016-09-01 04:49:55 EDT
This issue is not seen with glusterfs version 3.7.9-10.el7rhgs.x86_64.

Here are the steps that were performed,

1. Created a distributed replica volume and mounted it.
2. Created Directories from mount point.
4. Added new bricks to this volume. Note: Did not start rebalance here.
5. From mount point executed commands which look for those directories.
6. Verified  hash layout for those directories on newly added bricks.

Directory hash layout on the newly added brick are set to zeros and the layout for those directories are only fixed when performed rebalance.
Comment 4 Nithya Balachandran 2016-09-01 04:58:43 EDT
Thanks Prasad. Moving this to ON_QA based on comment#3.
Comment 5 Prasad Desala 2016-09-01 05:05:16 EDT
Based on Comment 3 moving this bug to Verified.
Comment 6 Nithya Balachandran 2016-09-06 04:39:57 EDT
Closing this BZ as per comment#5.

Note You need to log in before you can comment on or make changes to this bug.