Bug 1286117 - SIGSEGV if xdebug.trace_output_dir file can not be created
SIGSEGV if xdebug.trace_output_dir file can not be created
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: php-pecl-xdebug (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-27 06:21 EST by dev002
Modified: 2015-11-29 12:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-29 12:01:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dev002 2015-11-27 06:21:14 EST
Description of problem:
If xdebug.trace_output_dir is set to non existent dir in zts-php, results in seg fault.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.xdebug.trace_output_dir to nonexistent directory
2. run zts-php, or php ?
3. seg fault

Actual results:
seg fault

Expected results:
Warning about xdebug configuration, dir or similar

Additional info:
Comment 1 Remi Collet 2015-11-27 06:54:41 EST
Sorry, I cannot reproduce.

Can you please open an upstream bug on http://bugs.xdebug.org/ ?
Comment 2 dev002 2015-11-27 10:00:48 EST
$strace zts-php zts-app.php
...
stat("OUTDIR/trace.out..xt", 0x7fff1e79ba90) = -1 ENOENT (No such file or directory)
open("OUTDIR/trace.out..xt", O_WRONLY|O_CREAT|O_TRUNC, 0666) = -1 ENOENT (No such file or directory)
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0} ---
+++ killed by SIGSEGV (core dumped) +++



$ mkdir -p OUTDIR 
Run without problems



# chown anotheruser:anotheruser OUTDIR


$strace zts-php zts-app.php
 +++ killed by SIGSEGV (core dumped) +++
Comment 3 Derick Rethans 2015-11-29 10:12:05 EST
This has an Xdebug issue at http://bugs.xdebug.org/view.php?id=1215, which is resolved for the upcoming 2.4.0. You can consider this as "closed".
Comment 4 Remi Collet 2015-11-29 12:01:38 EST
Thanks Derick


As this bug doesn't seems critical, because of a result of a miss-configuration, I close it, the upstream fix will be part of next build.

Note You need to log in before you can comment on or make changes to this bug.